Bug 1297324 - Missing hammer command to generate subnet bootdisk iso
Missing hammer command to generate subnet bootdisk iso
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Bootdisk Plugin (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: GA
: --
Assigned To: Lukas Zapletal
Roman Plevka
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1498454
  Show dependency treegraph
 
Reported: 2016-01-11 03:40 EST by Sachin Ghai
Modified: 2017-10-04 07:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: rubygem-hammer_cli_foreman_bootdisk-0.1.3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1498454 (view as bug list)
Environment:
Last Closed: 2016-07-27 07:02:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13036 None None None 2016-04-22 12:07 EDT

  None (edit)
Description Sachin Ghai 2016-01-11 03:40:52 EST
Description of problem:
I was verifying bugzilla #1193933 and found that command to generate subnet bootdisk iso via hammer is missing.

Version-Release number of selected component (if applicable):
Satellite 6.1.6 compose3

How reproducible:
always

Steps to Reproduce:
1. hammer bootdisk subnet 
2.
3.

Actual results:
Missing hammer command to generate subnet bootdisk iso

Expected results:
cmd to generate subnet bootdisk iso should available via hammer:

hammer bootdisk subnet --subnet <local.lan>

Additional info:
Comment 3 Bryan Kearney 2016-01-12 13:11:48 EST
Created redmine issue http://projects.theforeman.org/issues/13162 from this bug
Comment 5 Bryan Kearney 2016-02-10 17:00:34 EST
This was addressed in 

commit b1052b60ff27d99f9635da8242c60d9808b1935a

of the hammer-cli-foreman-bootdisk 

I am moving this to POST and moving it to 6.2
Comment 6 Bryan Kearney 2016-02-18 12:37:59 EST
Connecting redmine issue http://projects.theforeman.org/issues/13036 from this bug
Comment 7 Bryan Kearney 2016-02-18 14:12:57 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/13036 has been closed
Comment 10 Roman Plevka 2016-04-05 05:33:45 EDT
FAILEDQA

this doesn't seem to exist in sat6.2.0 Snap6.1:

# hammer bootdisk -h
Usage:
    hammer bootdisk [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
 SUBCOMMAND                    subcommand
 [ARG] ...                     subcommand arguments

Subcommands:
 generic                       Download generic image
 host                          Download host image

Options:
 -h, --help                    print help

# hammer bootdisk subnet -h
Error: No such sub-command 'subnet'

See: 'hammer bootdisk --help'


# rpm -qa | grep bootdisk
tfm-rubygem-foreman_bootdisk-6.1.0-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-4.el7sat.noarch

moving back to Assigned
Comment 11 Lukas Zapletal 2016-04-06 04:00:52 EDT
No upstream release was done yet, the patch was merged on Jan 2016, I am asking Dominic for a release (gem-only release would be fine). Please rebase then over 0.1.4+ version.

commit b1052b60ff27d99f9635da8242c60d9808b1935a
Refs: 0.1.3-1-gb1052b6
Author:     Lukas Zapletal <lzap+git@redhat.com>
AuthorDate: Mon Jun 1 15:42:45 2015 +0200
Commit:     Dominic Cleal <dcleal@redhat.com>
CommitDate: Wed Feb 10 12:43:50 2016 +0000

    Fixes #13036 - added subnet subcommand
Comment 13 Bryan Kearney 2016-05-23 15:48:59 EDT
verified
version tested: satellite-6.2.0-12.1.el7sat.noarch
Steps to verify:



[vagrant@sat-test-rhel7 ~]$ hammer bootdisk subnet --subnet "bk"
[Foreman] Password for admin: 
Failed to download subnet disk image:
  ERF42-7296 [Foreman::Exception]: TFTP feature not enabled for subnet bk
Comment 14 Bryan Kearney 2016-07-27 07:02:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.