Bug 1297337 - The new default server url "subscription.rhsm.redhat.com" is not provided after clicking "default" button on gui
The new default server url "subscription.rhsm.redhat.com" is not provided aft...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: William Poteat
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 04:36 EST by Rehana
Modified: 2016-05-10 16:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:39:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rehana 2016-01-11 04:36:37 EST
Description of problem:
Observed that the new default server url "subscription.rhsm.redhat.com" is not displayed when user clicked on "Default" button on the gui/firstboot followed by a wrong server url entry

Version-Release number of selected component (if applicable):
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.16.7-1.el6
python-rhsm: 1.16.5-1.el6

How reproducible:
2/2

Steps to Reproduce:
1.launch subscription-manager gui
2.click on register button
3.observed that the default server url "subscription.rhsm.redhat.com" is displayed 
4. now enter a wrong server details , and click on "Default' button 

Actual results:
Observed that the "subscription.rhn.redhat.com" server details was replaced in the url 

Expected results:
Server value should be set to default hostname i.e "subscription.rhsm.redhat.com"

Additional info:
Comment 1 Rehana 2016-01-11 04:38:08 EST
Additional info:

Same is observed on cli 

# subscription-manager config --remove server.hostname
You have removed the value for section server and name hostname.
The default value for hostname will now be used.
# cat /etc/rhsm/rhsm.conf | grep hostname
# Server hostname:
hostname = subscription.rhn.redhat.com
proxy_hostname =
Comment 2 William Poteat 2016-01-18 14:14:06 EST
master commit be526f9b501b7621e8ed89844f4c6172ef3273c2
Comment 3 Chris Snyder 2016-01-19 14:31:39 EST
This BZ will be included in the next build of python-rhsm. Moving to the modified state.
Comment 5 Rehana 2016-01-20 06:13:20 EST
Retested on ,

subscription management server: 0.9.51.14-1
subscription management rules: 5.15.1
subscription-manager: 1.16.8-1.el6
python-rhsm: 1.16.6-1.el6

test observations 

1) On first boot -->  On clicking "Default' button bad server url was replaced with new correct server url "subscription.rhsm.redhat.com" 

2) Rested the same on subscription-manager-gui , observed that wrong serverurl was replaced by the new server url "subscription.rhsm.redhat.com" 

3) on cli, 

# subscription-manager config --remove server.hostname
You have removed the value for section server and name hostname.
The default value for hostname will now be used.

# cat /etc/rhsm/rhsm.conf | grep hostname
# Server hostname:
hostname = subscription.rhsm.redhat.com
proxy_hostname =

Marking Verified!!
Comment 7 errata-xmlrpc 2016-05-10 16:39:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.