Bug 1297342 - SELinux is preventing /usr/sbin/gssproxy from 'read' accesses on the lnk_file /usr/lib64/libcrypt.so.1.
SELinux is preventing /usr/sbin/gssproxy from 'read' accesses on the lnk_file...
Status: CLOSED DUPLICATE of bug 1297340
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3bd82dea182dab19c1da6d917b4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 04:46 EST by edo
Modified: 2016-01-11 08:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 08:40:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description edo 2016-01-11 04:46:52 EST
Description of problem:
SELinux is preventing /usr/sbin/gssproxy from 'read' accesses on the lnk_file /usr/lib64/libcrypt.so.1.

*****  Plugin restorecon (94.8 confidence) suggests   ************************

If you want to fix the label. 
/usr/lib64/libcrypt.so.1 default label should be lib_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /usr/lib64/libcrypt.so.1

*****  Plugin catchall_labels (5.21 confidence) suggests   *******************

If you want to allow gssproxy to have read access on the libcrypt.so.1 lnk_file
Then you need to change the label on /usr/lib64/libcrypt.so.1
Do
# semanage fcontext -a -t FILE_TYPE '/usr/lib64/libcrypt.so.1'
where FILE_TYPE is one of the following: admin_home_t, bin_t, boot_t, cert_t, device_t, devlog_t, etc_runtime_t, etc_t, file_context_t, fonts_cache_t, fonts_t, gssproxy_var_lib_t, gssproxy_var_run_t, ld_so_t, lib_t, locale_t, man_cache_t, man_t, net_conf_t, proc_t, root_t, rpm_script_tmp_t, security_t, shell_exec_t, src_t, sssd_var_lib_t, system_conf_t, system_db_t, textrel_shlib_t, tmp_t, usr_t, var_run_t, var_t. 
Then execute: 
restorecon -v '/usr/lib64/libcrypt.so.1'


*****  Plugin catchall (1.44 confidence) suggests   **************************

If you believe that gssproxy should be allowed read access on the libcrypt.so.1 lnk_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gssproxy /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:gssproxy_t:s0
Target Context                system_u:object_r:unlabeled_t:s0
Target Objects                /usr/lib64/libcrypt.so.1 [ lnk_file ]
Source                        gssproxy
Source Path                   /usr/sbin/gssproxy
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gssproxy-0.4.1-4.fc23.x86_64
Target RPM Packages           glibc-2.22-7.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-300.fc23.x86_64 #1 SMP Tue
                              Jan 5 23:31:01 UTC 2016 x86_64 x86_64
Alert Count                   4
First Seen                    2016-01-10 13:25:02 CET
Last Seen                     2016-01-11 09:20:00 CET
Local ID                      291c2d83-d8d2-45b9-8adb-d3ae30b101ae

Raw Audit Messages
type=AVC msg=audit(1452500400.544:109): avc:  denied  { read } for  pid=948 comm="gssproxy" name="libcrypt.so.1" dev="dm-1" ino=3193829 scontext=system_u:system_r:gssproxy_t:s0 tcontext=system_u:object_r:unlabeled_t:s0 tclass=lnk_file permissive=1


type=SYSCALL msg=audit(1452500400.544:109): arch=x86_64 syscall=open success=yes exit=ENXIO a0=5572623e9c50 a1=80000 a2=5572623ea440 a3=7f71a4f71ba8 items=0 ppid=899 pid=948 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=gssproxy exe=/usr/sbin/gssproxy subj=system_u:system_r:gssproxy_t:s0 key=(null)

Hash: gssproxy,gssproxy_t,unlabeled_t,lnk_file,read

Version-Release number of selected component:
selinux-policy-3.13.1-158.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-300.fc23.x86_64
type:           libreport
Comment 1 Daniel Walsh 2016-01-11 08:40:42 EST

*** This bug has been marked as a duplicate of bug 1297340 ***

Note You need to log in before you can comment on or make changes to this bug.