Bug 1297344 - SELinux is preventing /usr/bin/abrt-action-save-package-data from 'write' accesses on the file /var/lib/rpm/Group.
SELinux is preventing /usr/bin/abrt-action-save-package-data from 'write' acc...
Status: CLOSED DUPLICATE of bug 1297340
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:53b69c22b90dfec56a10860d72a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 04:47 EST by edo
Modified: 2016-01-11 08:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 08:45:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description edo 2016-01-11 04:47:59 EST
Description of problem:
SELinux is preventing /usr/bin/abrt-action-save-package-data from 'write' accesses on the file /var/lib/rpm/Group.

*****  Plugin restorecon (94.8 confidence) suggests   ************************

If you want to fix the label. 
/var/lib/rpm/Group default label should be rpm_var_lib_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /var/lib/rpm/Group

*****  Plugin catchall_labels (5.21 confidence) suggests   *******************

If you want to allow abrt-action-save-package-data to have write access on the Group file
Then you need to change the label on /var/lib/rpm/Group
Do
# semanage fcontext -a -t FILE_TYPE '/var/lib/rpm/Group'
where FILE_TYPE is one of the following: abrt_etc_t, abrt_tmp_t, abrt_upload_watch_tmp_t, abrt_var_cache_t, abrt_var_log_t, abrt_var_run_t, afs_cache_t, initrc_tmp_t, mock_var_lib_t, postfix_postdrop_t, puppet_tmp_t, rpm_log_t, rpm_var_cache_t, rpm_var_run_t, sysfs_t, user_cron_spool_t, user_tmp_t. 
Then execute: 
restorecon -v '/var/lib/rpm/Group'


*****  Plugin catchall (1.44 confidence) suggests   **************************

If you believe that abrt-action-save-package-data should be allowed write access on the Group file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-action-sav /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:var_lib_t:s0
Target Objects                /var/lib/rpm/Group [ file ]
Source                        abrt-action-sav
Source Path                   /usr/bin/abrt-action-save-package-data
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-2.7.1-1.fc23.x86_64
Target RPM Packages           rpm-4.13.0-0.rc1.6.fc23.x86_64
                              rpm-4.13.0-0.rc1.7.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-158.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.3.3-300.fc23.x86_64 #1 SMP Tue
                              Jan 5 23:31:01 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-01-09 00:15:01 CET
Last Seen                     2016-01-09 00:15:01 CET
Local ID                      59dbf4c2-d9be-40a8-aea1-42538ed3bde1

Raw Audit Messages
type=AVC msg=audit(1452294901.66:1363): avc:  denied  { write } for  pid=8981 comm="abrt-action-sav" name="Group" dev="dm-1" ino=3028559 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_lib_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1452294901.66:1363): arch=x86_64 syscall=open success=yes exit=ENOEXEC a0=55a98560e940 a1=2 a2=0 a3=55a98560e7f0 items=0 ppid=8980 pid=8981 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-action-sav exe=/usr/bin/abrt-action-save-package-data subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrt-action-sav,abrt_t,var_lib_t,file,write

Version-Release number of selected component:
selinux-policy-3.13.1-158.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.3.3-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1209244
Comment 1 Miroslav Grepl 2016-01-11 08:45:30 EST

*** This bug has been marked as a duplicate of bug 1297340 ***

Note You need to log in before you can comment on or make changes to this bug.