Bug 1297373 - [write-behind] : Write/Append to a full volume causes fuse client to crash
[write-behind] : Write/Append to a full volume causes fuse client to crash
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: write-behind (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
: ZStream
Depends On: 1297004
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 05:42 EST by Raghavendra G
Modified: 2016-06-16 09:54 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1297004
Environment:
Last Closed: 2016-06-16 09:54:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-11 05:51:23 EST
REVIEW: http://review.gluster.org/13213 (performance/write-behind: fix memory corruption) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Vijay Bellur 2016-01-12 01:15:45 EST
REVIEW: http://review.gluster.org/13213 (performance/write-behind: fix memory corruption) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 3 Vijay Bellur 2016-01-13 07:14:02 EST
REVIEW: http://review.gluster.org/13213 (performance/write-behind: fix memory corruption) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 4 Vijay Bellur 2016-01-13 08:44:49 EST
REVIEW: http://review.gluster.org/13213 (performance/write-behind: fix memory corruption) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 5 Vijay Bellur 2016-01-14 00:42:17 EST
COMMIT: http://review.gluster.org/13213 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 1b9174d35dc113f97fd5cec811633853cef269f3
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Mon Jan 11 16:17:29 2016 +0530

    performance/write-behind: fix memory corruption
    
    1. while handling short writes, __wb_fulfill_short_write would've freed
       current request before moving on to next in the list if request is not
       big enough to accomodate completed number of bytes. So, make sure to
       save next member before invoking __wb_fulfill_short_write on current
       request. Also handle the case where request is exactly the size of
       remaining completed number of bytes.
    
    2. When write request is unwound because there is a conflicting failed
       liability, make sure its deleted from tempted list. Otherwise there
       will be two unwinds (one as part handling a failed request in
       wb_do_winds and another in wb_do_unwinds).
    
    Change-Id: Id1b54430796b19b956d24b8d99ab0cdd5140e4f6
    BUG: 1297373
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/13213
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
Comment 6 Niels de Vos 2016-06-16 09:54:13 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.