Bug 1297374 - after selecting a font for view, the "Sample" tab does not load sample text correctly
after selecting a font for view, the "Sample" tab does not load sample text c...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fontmatrix (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 05:43 EST by Emily Tench
Modified: 2016-04-23 03:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-23 03:15:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing error state (433.89 KB, image/png)
2016-01-11 05:43 EST, Emily Tench
no flags Details

  None (edit)
Description Emily Tench 2016-01-11 05:43:42 EST
Created attachment 1113570 [details]
screenshot showing error state

Description of problem:

after selecting a font for view, the "Sample" tab does not load sample text correctly - font displays correctly, playground works correctly, but sample text looks like it may be an error message or fragment of code

Version-Release number of selected component (if applicable):

fontmatrix-0.9.99-22.r1218.fc23

How reproducible:

very


Steps to Reproduce:
1. open fontmatrix
2. double click any font
3. "Sample" tab is selected by default and shows incorrect sample text

Actual results:

screenshot included : displays commas, parenthesis, semicolons, etc.


Expected results:

loading a meaningful sample of glyphs used in font, or text configured in preferences


Additional info:

I believe this was working properly in previous releases, but I am not 100% certain. The current user id was created as a clean home directory on a new install of Fedora Workstation 23 - so no settings have been carried over in the home directory from other distributions or from previous uses of fontmatrix.
Comment 1 Emily Tench 2016-01-11 06:25:41 EST
current release source from fontmatrix repository (not the source rpm) compiles and runs correctly.
Comment 2 Parag Nemade 2016-01-14 09:52:23 EST
Can you share what font you selected on which locale? I need this to reproduce this bug. Also take a screenshot of what sample text is looking for you?

I think font will render the selected language's sample text only when that font contains glyphs to render that sample text.

E.g. I selected Devanagari language font and sample text Hindi and rendering of sample text becomes readable. Otherwise you will see only commas, parenthesis etc...
Comment 3 Parag Nemade 2016-04-23 03:15:47 EDT
Please reopen if you still see this bug by providing requested information above.

Note You need to log in before you can comment on or make changes to this bug.