Bug 129742 - No retries when having kickstart is having problem retrieving files
No retries when having kickstart is having problem retrieving files
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 09:05 EDT by Trond Eivind Glomsrød
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 03:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trond Eivind Glomsrød 2004-08-12 09:05:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
Anaconda/kickstart doesn't retry after a short period of time to
retrieve a kickstart file, mount a partition via NFS etc.

It should try again after a couple of seconds... some
card/driver/switch combinations take a short time to get the
connection properly up. In particular, the tg3 driver... which has
huge problems being kickstarted in RHEL 3 U2 on gigabit, but works
with other cards, standard RHEL3 (no U2) or if put through a dumb 100
mbit switch. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install RHEL3 U2 with kickstart on a node using gigabit ethernet, a 
managed switch and a card using the tg3 driver on the node.

Notice the inability of getting the kickstart file via http or nfs, as
it's attempted before everything is OK, networkwise.
    

Expected Results:  it should fail the first time, try again after a a
couple of second and get the files.

Additional info:
Comment 1 Jeremy Katz 2004-08-12 14:08:54 EDT
http://people.redhat.com/~katzj/initrd-link-2-x86_64.img will be
happier (also available for i386 and ia64 with the obvious name) for
U2.  U3 will include this fix as well.
Comment 2 Trond Eivind Glomsrød 2004-08-12 16:54:07 EDT
Pump needs to try harder for DHCP too, this would solve problems with
spanning trees in switches for kickstart+pxe installs
Comment 3 Need Real Name 2004-09-16 12:13:29 EDT
The fix doesn't seem to be in the x86_64 U3 release.  I still get
timeout with a dell Power Connect 5224 switch and a precision 470
x86_64 machine.  I also tried with your image for i386 and x86_64 and
got the request to not come in at all.
Comment 4 Trond Eivind Glomsrød 2004-10-25 06:59:57 EDT
The fix changes the issues for some configurations, but it is still
present in others - where U1 works.

HP DL145 with procurve 2650 switches is one example... bios PXE and
initial OS DHCP works, but the installer doesn't succeed at first
attempt (too fast) or retry when retrieving the kickstart file.

(ugly workaround: set half duplex on a switch).

Various Dell nodes on Cisco switches exchibited the same problem, but
not as consistently.
Comment 5 Jeremy Katz 2004-10-25 11:04:58 EDT
Can you try with the U4 beta?  It should have another set of changes
that improves things
Comment 6 Trond Eivind Glomsrød 2004-11-16 03:28:07 EST
U4 beta worked with DL145 last week, while U3 did not.

Note You need to log in before you can comment on or make changes to this bug.