Bug 1297430 - RFE: chroot_scan should extract files preserving ownership and mode
RFE: chroot_scan should extract files preserving ownership and mode
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 08:44 EST by Alejandro Alvarez
Modified: 2017-04-12 20:16 EDT (History)
7 users (show)

See Also:
Fixed In Version: mock-1.3.4-1.fc25 mock-1.3.4-1.fc24 mock-1.3.4-1.el7 mock-1.3.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-08 08:28:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alejandro Alvarez 2016-01-11 08:44:36 EST
Description of problem:

When using the plugin chroot_scan to extract test logs (in our case, generated during %check), the generated logs are extracted owned by root.root, even if the original files were owned by whoever is running mock. I guess this is because the files are copied out being root, while the tests are run dropping privileges first.

I have patched it using --preserve=ownership,mode (see
https://github.com/ayllon/mock/commit/fe93db6267218919db812adc053df18dd5362f1f
), although maybe there are better solutions (chown?)
Comment 1 Miroslav Suchý 2017-02-21 11:06:06 EST
I commited the preservation of mode as commit 12e8682

The ownership have to be reset to current user, otherwise user can be unable to even remove such files. This has been recently addressed by:

https://github.com/rpm-software-management/mock/pull/47
Comment 2 Fedora Update System 2017-02-27 12:55:41 EST
mock-1.3.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c433a692a
Comment 3 Fedora Update System 2017-02-27 12:56:02 EST
mock-1.3.4-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-2c7e8574bf
Comment 4 Fedora Update System 2017-02-27 12:56:25 EST
mock-1.3.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3cb1bb5aa5
Comment 5 Fedora Update System 2017-02-27 12:56:47 EST
mock-1.3.4-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-89e17056c0
Comment 6 Fedora Update System 2017-02-28 20:48:41 EST
mock-1.3.4-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-89e17056c0
Comment 7 Fedora Update System 2017-02-28 21:50:37 EST
mock-1.3.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c433a692a
Comment 8 Fedora Update System 2017-02-28 21:53:29 EST
mock-1.3.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3cb1bb5aa5
Comment 9 Fedora Update System 2017-03-01 12:17:37 EST
mock-1.3.4-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-2c7e8574bf
Comment 10 Vit Ry 2017-03-01 14:50:56 EST
Should be fully fixed since https://github.com/rpm-software-management/mock/pull/50
Comment 11 Fedora Update System 2017-03-02 05:21:33 EST
mock-1.3.5-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-2c7e8574bf
Comment 12 Fedora Update System 2017-03-02 22:54:54 EST
mock-1.3.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2017-03-02 23:17:12 EST
mock-1.3.5-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-2c7e8574bf
Comment 14 Fedora Update System 2017-03-08 08:28:29 EST
mock-1.3.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2017-03-15 09:48:15 EDT
mock-1.3.4-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2017-04-12 20:16:37 EDT
mock-1.3.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.