Bug 1297434 - CF 3.2: Switching user groups invalidates browser/version/os information, which might be disabling the console buttons on the VM.
CF 3.2: Switching user groups invalidates browser/version/os information, whi...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity urgent
: GA
: 5.4.5
Assigned To: Harpreet Kataria
Pete Savage
ui:group
: ZStream
Depends On: 1297074
Blocks: 1297432
  Show dependency treegraph
 
Reported: 2016-01-11 09:06 EST by Chris Pelland
Modified: 2016-03-29 10:16 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, switching user groups invalidated browser/version/OS information, which in turn disabled the console buttons on the VM. This was caused as session.clear call cleared out user's browser information that was being saved in session when user logged in. This bug has been fixed by saving and restoring certain keys in session hash for later use. Console buttons are now working as expected.
Story Points: ---
Clone Of: 1297074
Environment:
Last Closed: 2016-03-29 10:16:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Harpreet Kataria 2016-01-11 13:07:06 EST
https://github.com/ManageIQ/manageiq/pull/6125
Comment 3 CFME Bot 2016-01-11 17:36:06 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/93308442cfc4c70a1b8806a45ac20296512b04fb

commit 93308442cfc4c70a1b8806a45ac20296512b04fb
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 11 09:08:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jan 11 13:03:33 2016 -0500

    Need to restore certain keys back into session hash
    
    session.clear call clears out user's browser information that's being saved in session when user logs in, need to save & restore certain keys in session hash for later use.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434

 app/controllers/dashboard_controller.rb       | 12 ++++--------
 spec/controllers/dashboard_controller_spec.rb | 25 +++++++++++++++++++++++++
 2 files changed, 29 insertions(+), 8 deletions(-)
Comment 4 CFME Bot 2016-01-11 18:51:07 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7b5fed5d476f44941cd93f6a483fcf5209074e67

commit 7b5fed5d476f44941cd93f6a483fcf5209074e67
Merge: e0890cc fbd0a8b
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Jan 11 18:40:08 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Jan 11 18:40:08 2016 -0500

    Merge branch '55z_pr_6125' into '5.5.z'
    
    Need to restore certain keys back into session hash
    
    session.clear call clears out user's browser information that's being saved in session when user logs in, need to save & restore certain keys in session hash for later use.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 9330844)
    
    @dclarizi this is clean 5.5.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6125
    
    See merge request !702

 app/controllers/dashboard_controller.rb       | 12 ++++--------
 spec/controllers/dashboard_controller_spec.rb | 25 +++++++++++++++++++++++++
 2 files changed, 29 insertions(+), 8 deletions(-)
Comment 5 CFME Bot 2016-01-11 18:51:20 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=fbd0a8bd3dc94e134cb44e5c30174b5cb22defde

commit fbd0a8bd3dc94e134cb44e5c30174b5cb22defde
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 11 09:08:27 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jan 11 17:18:15 2016 -0500

    Need to restore certain keys back into session hash
    
    session.clear call clears out user's browser information that's being saved in session when user logs in, need to save & restore certain keys in session hash for later use.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 9330844)

 app/controllers/dashboard_controller.rb       | 12 ++++--------
 spec/controllers/dashboard_controller_spec.rb | 25 +++++++++++++++++++++++++
 2 files changed, 29 insertions(+), 8 deletions(-)
Comment 6 CFME Bot 2016-01-12 14:29:52 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1f6f5ea6243adf62f6104357e84b586be487707c

commit 1f6f5ea6243adf62f6104357e84b586be487707c
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Jan 11 17:24:58 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Jan 12 11:25:42 2016 -0500

    Need to restore certain keys back into session hash
    
    session.clear call clears out user's browser information that's being saved in session when user logs in, need to save & restore certain keys in session hash for later use.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 9330844)

 vmdb/app/controllers/dashboard_controller.rb       | 12 ++++-------
 vmdb/spec/controllers/dashboard_controller_spec.rb | 25 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 8 deletions(-)
Comment 7 CFME Bot 2016-01-12 14:30:20 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a2700819614e7e239624522b2fdea4451147b9fc

commit a2700819614e7e239624522b2fdea4451147b9fc
Merge: 711d46a 1f6f5ea
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Jan 12 14:04:31 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Jan 12 14:04:31 2016 -0500

    Merge branch '54z_pr_6125' into '5.4.z'
    
    Need to restore certain keys back into session hash
    
    session.clear call clears out user's browser information that's being saved in session when user logs in, need to save & restore certain keys in session hash for later use.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 9330844)
    
    @dclarizi please review, this is clean 5.4.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6125
    
    See merge request !703

 vmdb/app/controllers/dashboard_controller.rb       | 12 ++++-------
 vmdb/spec/controllers/dashboard_controller_spec.rb | 25 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 8 deletions(-)
Comment 12 CFME Bot 2016-02-01 12:41:47 EST
Detected commit referencing this ticket while ticket status is ON_QA.
Comment 13 CFME Bot 2016-02-01 16:36:53 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7844fd4473ec2c9c256b602c3c40ae1ba66c16d1

commit 7844fd4473ec2c9c256b602c3c40ae1ba66c16d1
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 1 10:03:01 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Feb 1 10:07:38 2016 -0500

    Changed session.merge! to session.update
    
    session.merge! was not setting keys in Session object in the rails app.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434

 app/controllers/dashboard_controller.rb       | 2 +-
 spec/controllers/dashboard_controller_spec.rb | 5 +++++
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 15 CFME Bot 2016-02-02 15:50:09 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=d1fb8f1ecc724f76dcd4c362c757d6e9259654f1

commit d1fb8f1ecc724f76dcd4c362c757d6e9259654f1
Merge: 1520fa7 8e26fab
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Feb 2 15:29:04 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Feb 2 15:29:04 2016 -0500

    Merge branch '54z_pr_6459' into '5.4.z'
    
    Changed session.merge! to session.update
    
    session.merge! was not setting keys in Session object in the rails app.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 7844fd4)
    
    @dclarizi please review, this is clean 5.4.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6459
    
    See merge request !764

 vmdb/app/controllers/dashboard_controller.rb       | 2 +-
 vmdb/spec/controllers/dashboard_controller_spec.rb | 5 +++++
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 16 CFME Bot 2016-02-02 15:50:23 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8e26fab55baa7467b8d9aa3c4a726fa50c476587

commit 8e26fab55baa7467b8d9aa3c4a726fa50c476587
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 1 16:58:38 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Feb 1 16:58:38 2016 -0500

    Changed session.merge! to session.update
    
    session.merge! was not setting keys in Session object in the rails app.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 7844fd4)

 vmdb/app/controllers/dashboard_controller.rb       | 2 +-
 vmdb/spec/controllers/dashboard_controller_spec.rb | 5 +++++
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 18 CFME Bot 2016-02-10 14:01:18 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=81a5df0705cee400f67d8de5ec5547ab17d892d9

commit 81a5df0705cee400f67d8de5ec5547ab17d892d9
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 1 10:03:01 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Feb 9 13:55:35 2016 -0500

    Changed session.merge! to session.update
    
    session.merge! was not setting keys in Session object in the rails app.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 7844fd4)

 app/controllers/dashboard_controller.rb       | 2 +-
 spec/controllers/dashboard_controller_spec.rb | 5 +++++
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 19 CFME Bot 2016-02-10 14:01:42 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=dfaa7f72b3cbc37f76a048da0f2ad8949c0503e3

commit dfaa7f72b3cbc37f76a048da0f2ad8949c0503e3
Merge: 65bd384 81a5df0
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Feb 10 13:49:38 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Feb 10 13:49:38 2016 -0500

    Merge branch '55z_pr_6459' into '5.5.z'
    
    Changed session.merge! to session.update
    
    session.merge! was not setting keys in Session object in the rails app.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297432
    https://bugzilla.redhat.com/show_bug.cgi?id=1297074
    https://bugzilla.redhat.com/show_bug.cgi?id=1297434
    (cherry picked from commit 7844fd4)
    
    @dclarizi please review, this is clean 5.5.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6459
    
    See merge request !763

 app/controllers/dashboard_controller.rb       | 2 +-
 spec/controllers/dashboard_controller_spec.rb | 5 +++++
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 21 CFME Bot 2016-02-15 10:37:08 EST
Detected commit referencing this ticket while ticket status is ON_QA.
Comment 22 Pete Savage 2016-03-18 14:10:56 EDT
Verified in 5.4.5.2
Comment 24 errata-xmlrpc 2016-03-29 10:16:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.