Bug 1297448 - Rpmlint should not depend on python2
Rpmlint should not depend on python2
Status: CLOSED DUPLICATE of bug 1243292
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 09:41 EST by Pavel Raiskup
Modified: 2016-12-21 01:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 15:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2016-01-11 09:41:52 EST
Steps to reproduce:

  $ mock  -r fedora-rawhide-x86_64 --init
  $ mock  -r fedora-rawhide-x86_64 --install rpmlint
  $ mock  -r fedora-rawhide-x86_64 --shell
  <mock-chroot>sh-4.3# rpmlint rpmlint
  sh: /usr/bin/python: No such file or directory
  rpmlint.noarch: W: incoherent-version-in-changelog 1.8-3 ['1.8-4.fc24',
  '1.8-4']
  rpmlint.noarch: W: no-manual-page-for-binary el4-rpmlint
  rpmlint.noarch: W: no-manual-page-for-binary el5-rpmlint
  1 packages and 0 specfiles checked; 0 errors, 3 warnings.

See the '/usr/bin/python: No such file or directory' message.
Comment 1 Ville Skyttä 2016-01-11 15:07:16 EST
Harmless warning (from rpm, see dupe bug), not a dependency.

*** This bug has been marked as a duplicate of bug 1243292 ***
Comment 2 Pavel Raiskup 2016-12-21 00:52:18 EST
Obviously not a DUPLICATE because bug#1243292 is not yet resolved.. and
rpmlint pulls the python3 package ATM which (seems to) resolved the issues.
If there's better reason, please tell.
Comment 3 Pavel Raiskup 2016-12-21 01:01:25 EST
I was wrong.  For some reason python (2) was pulled by 'mock --init'.  Sorry
for rush.  This still _is_ a bug.

*** This bug has been marked as a duplicate of bug 1243292 ***

Note You need to log in before you can comment on or make changes to this bug.