This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 129745 - mkinitrd fails to pull scsi (sata) modules into the initrd image?
mkinitrd fails to pull scsi (sata) modules into the initrd image?
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 09:33 EDT by Kaj J. Niemi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 07:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2004-08-12 09:33:51 EDT
Description of problem:

Looking at how the mkinitrd logic works the following seems to happen:

- If noscsi is not set
  - Grep modulefile (/etc/modules.conf in this case) for
"alias[[:space:]]\+scsi_hostadapter"
  - Do other neat things

As far as I can tell the \+scsi_hostadapter around line 363 should
instead be +scsi_hostadapter (without \) ?


Version-Release number of selected component (if applicable):
mkinitrd-4.x, mkinitrd-3.5.x too.

How reproducible:
On SATA hardware always?

Steps to Reproduce:
1. Install new kernel (rpm -ivh kernel-something.i686.rpm)
2. Set default=0 in grub since it does not happen automagically?
3. Reboot
4. Watch it fail.
  
Actual results:


Expected results:
Should boot normally.

Additional info:
Workaround is to manually issue:

% rm -f /boot/initrd-2.6.7-1.517smp.img
% mkinitrd --preload=scsi_mod --preload=sd_mod --with=ata_piix
/boot/initrd-2.6.7-1.517smp.img 2.6.7-1.517smp


% cat /etc/modules.conf|egrep scsi
alias scsi_hostadapter ata_piix
Comment 1 Kaj J. Niemi 2004-08-12 14:00:50 EDT
Same thing with 4.0.5. As far as I can see this is a typo, the usb
section above the scsi section doesn't have "\" either.
Comment 2 Jeremy Katz 2004-08-12 14:14:04 EDT
This works fine for me here...  can you attach your /etc/modprobe.conf?

[katzj@orodruin ~]$ cat /etc/modprobe.conf
alias eth0 e1000
alias scsi_hostadapter ata_piix
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ieee1394-controller ohci1394
alias sound-slot-0 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 ||:
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0
[katzj@orodruin ~]$ grep "alias[[:space:]]\+scsi_hostadapter"
/etc/modprobe.conf | grep -v '^[ ]*#' | LC_ALL=C sort -u | awk '{
print $3 }'
ata_piix
Comment 3 Kaj J. Niemi 2004-08-12 15:02:50 EDT
Hmmm very interesting.. /etc/modprobe.conf is missing "alias
scsi_hostadapter ata_piix".

% cat /etc/modprobe.conf
include /etc/modprobe.conf.dist
alias eth0 8139too
alias scsi_hostadapter ata_piix
alias block-major-2 off
alias block-major-3 off
alias block-major-22 off
alias block-major-33 off
alias block-major-34 off
alias block-major-56 off
alias block-major-57 off
alias char-major-89 i2c-dev
alias floppy off
%

I'll add it there and see what happens.
Comment 4 Kaj J. Niemi 2004-08-12 15:03:30 EDT
Next time I cat something better copy-paste "before" instead of
"after".. need some sleep. :)
Comment 5 Kaj J. Niemi 2004-09-21 07:11:43 EDT
I'll close this since the problem was between the keyboard and chair.
;-) Thanks.

Note You need to log in before you can comment on or make changes to this bug.