This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297505 - postgresql-9.4.5-1.fc23.i686 conflicts with file from package postgresql-9.4.5-1.fc23.x86_64
postgresql-9.4.5-1.fc23.i686 conflicts with file from package postgresql-9.4....
Status: CLOSED DUPLICATE of bug 1190346
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 12:17 EST by Yupeng Chang
Modified: 2016-01-11 19:18 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 19:18:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yupeng Chang 2016-01-11 12:17:51 EST
Description of problem:
postgresql-9.4.5-1.fc23.i686 conflicts with file from package postgresql-9.4.5-1.fc23.x86_64

Version-Release number of selected component (if applicable):


How reproducible:
sudo dnf install postgresql-devel.i686 postgresql-devel.x86_64

Steps to Reproduce:
1.
2.
3.

Actual results:
dnf reports errors:
  file /usr/share/doc/postgresql/README.rpm-dist from install of postgresql-9.4.5-1.fc23.i686 conflicts with file from package postgresql-9.4.5-1.fc23.x86_64
  file /usr/include/pg_config_ext.h from install of postgresql-devel-9.4.5-1.fc23.i686 conflicts with file from package postgresql-devel-9.4.5-1.fc23.x86_64
  file /usr/include/pgsql/server/pg_config_ext.h from install of postgresql-devel-9.4.5-1.fc23.i686 conflicts with file from package postgresql-devel-9.4.5-1.fc23.x86_64

Expected results:

Both i686 and x86_64 devel packages can be installed.

Additional info:
Comment 1 Pavel Raiskup 2016-01-11 19:18:41 EST
This has been fixed in git [1] but not yet updated in F23, thanks for the
report.
[1] http://pkgs.fedoraproject.org/cgit/rpms/postgresql.git/commit/?h=f23&id=ca2f2daa2dde4650d1a0134d917c036337a00c25

*** This bug has been marked as a duplicate of bug 1190346 ***

Note You need to log in before you can comment on or make changes to this bug.