This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 129754 - IBM java crashes on jedit
IBM java crashes on jedit
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: dff
http://www.jedit.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 11:10 EDT by Göran Uddeborg
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 05:29:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2004-08-12 11:10:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
(I enter this for the distribution component since java-1.4.1-ibm is
missing from the component list.)

When trying to run jedit using the java from the extras channel, it
crashes on x86_64.  On i386 it works fine.

Version-Release number of selected component (if applicable):
java-1.4.1-ibm-1.4.1.2-1jpp_2rh

How reproducible:
Always

Steps to Reproduce:
1. Install jedit-4.1-1 RPM from http://www.jedit.org
2. Run jedit

Actual Results:  First an error message:
JVMLH052: Guard page resetting failed (errno=13).

Then a crash:
Abort (core dumped)

Expected Results:  A jedit GUI started.

Additional info:
I know of course jedit isn't part of the distribution, and not
supported by you.  But I get the impression this is a bug in the java
machine, which only happens to be triggered by jedit.  Thus, this bug
report makes sense.
Comment 1 Richard Porter 2004-09-26 15:32:23 EDT
I've just received the same error when trying to run JBoss 4.0.

JVMLH052: Guard page resetting failed (errno=13).
./run.sh: line 186: 22176 Aborted                 "$JAVA" $JAVA_OPTS
-Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" -classpath
"$JBOSS_CLASSPATH" org.jboss.Main "$@"

If it's relevant, I'm running on a dual processor machine.

uname output:
Linux oscar 2.4.21-15.EL #1 SMP Thu Apr 22 00:09:47 EDT 2004 x86_64
x86_64 x86_64 GNU/Linux
Comment 2 Richard Porter 2004-09-26 16:05:24 EDT
I just downloaded a new kernel and started up again. The problem for
me with JBoss is resolved.
I was using kernel 2.4.21-15.EL, now I'm running kernel 2.4.21-20.EL.
Comment 3 Göran Uddeborg 2004-10-01 05:29:21 EDT
It works for us to start jedit now.  It does not seem to depend on the
kernel, but the upgrade of java to 1.4.2 made a difference.

Note You need to log in before you can comment on or make changes to this bug.