Bug 1297551 - Web UI inconsistencies with the 2D. Configuration > Data Center Name and Cluster Name fields
Web UI inconsistencies with the 2D. Configuration > Data Center Name and Clus...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
All All
unspecified Severity low
: ga
: 1.0
Assigned To: cchase
Tasos Papaioannou
: Triaged
: 1326873 (view as bug list)
Depends On:
Blocks: rhci-sprint-14 qci-sprint-17
  Show dependency treegraph
 
Reported: 2016-01-11 15:18 EST by Tasos Papaioannou
Modified: 2016-09-13 12:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:23:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tasos Papaioannou 2016-01-11 15:18:59 EST
Description of problem:

1.) Change the value in the Data Center Name field from "Default" to something else, then restore it back to "Default". The warning text "Note: You must change the cluster name after changing the database name" does not go away, and the Next button remains disabled, until I do the same to the Cluster Name field.

2.) If instead I first change the Cluster Name field, then undo the change, the Next button remains disabled but there is no corresponding warning text.

In both of these cases, I would expect the warning text to disappear and the Next button to be enabled again.

3.) If I change either the Data Center Name or Cluster Name from "Default" to "Default " (trailing space), there is no warning text, but the Next button is disabled. Warning text only appears once I add a non-space character, e.g., "Default 1":

"must contain only 'A-Z', 'a-z', '0-9', '_' or '-' characters"

If spaces aren't allowed, then the warning text should be triggered as soon as one is entered.

4.) If I click on 2C. Hypervisors, then back on 2D. Configuration (or Back then Next) after entering bad values in the Data Center Name or Cluster Name fields, then the warning text disappears, and I can edit the field with no further warning until I click elsewhere or tab off of the field.

5.) Since the field is called "Data Center Name", would it make more sense for the warning text to refer to it as such instead of as "database name"?

Version-Release number of selected component (if applicable):

RHCI-6.0-RHEL-7-20160107.t.1

How reproducible:

100%

Steps to Reproduce:

See description above.

Actual results:

Inconsistent warnings about data center name and cluster name values.

Expected results:

Consistent warnings.

Additional info:
Comment 1 cchase 2016-04-05 14:44:06 EDT
https://github.com/fusor/fusor/pull/745

Changing the field back to "Default" or blank will get rid notifications to change the other defaulted field.

Any time one field is changed from default, the other field will show a validation note that it needs to be changed if it's in the default state.
Comment 2 Tasos Papaioannou 2016-06-22 12:08:54 EDT
Tested on QCI-1.2-RHEL-7-20160621.t.0. The issues mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1297551#c0 have been addressed, except for one small point:

If I change the Data Center Name from Default to, e.g., Lab, then the warning text that appears underneath the Cluster Name field is:

"Note: You must change the cluster name after changing the cluster name"

It should say:

"Note: You must change the cluster name after changing the data center name"

If instead I change the Cluster Name field first, then the warning text below the Data Center Name field is correct:

"Note: You must change the data center name after changing the cluster name"
Comment 3 cchase 2016-06-23 17:29:47 EDT
https://github.com/fusor/fusor/pull/978

fixed cluster name validation to say:

"Note: You must change the cluster name after changing the data center name"
Comment 4 cchase 2016-06-24 09:07:36 EDT
*** Bug 1326873 has been marked as a duplicate of this bug. ***
Comment 5 John Matthews 2016-07-05 13:34:17 EDT
QCI-1.2-RHEL-7-20160705.t.1
Comment 6 Tasos Papaioannou 2016-07-07 13:05:47 EDT
Verified on QCI-1.2-RHEL-7-20160705.t.1.
Comment 12 errata-xmlrpc 2016-09-13 12:23:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.