Bug 1297556 - Modem Connection not established (GSM/Broadband)
Modem Connection not established (GSM/Broadband)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 15:31 EST by Christian Groove
Modified: 2016-07-27 05:06 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:06:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Groove 2016-01-11 15:31:55 EST
Description of problem:

Since F23 (or before F22 see Bug 1234727) it is
not possible to plugin an usb modem and connect
to the broadband internet.
In F21 it worked without any problem.
	

Version-Release number of selected component (if applicable):
NetworkManager-team-1.0.10-2.fc23.x86_64
NetworkManager-wwan-1.0.10-2.fc23.x86_64
NetworkManager-1.0.10-2.fc23.x86_64
NetworkManager-l2tp-0.9.8.7-4.fc23.x86_64
NetworkManager-openvpn-1.0.8-1.fc23.x86_64
NetworkManager-openswan-1.0.8-1.fc23.x86_64
NetworkManager-iodine-gnome-0.0.5-2.fc23.x86_64
NetworkManager-pptp-1.1.0-2.20150428git695d4f2.fc23.x86_64
NetworkManager-openvpn-gnome-1.0.8-1.fc23.x86_64
NetworkManager-pptp-gnome-1.1.0-2.20150428git695d4f2.fc23.x86_64
NetworkManager-libnm-1.0.10-2.fc23.x86_64
NetworkManager-adsl-1.0.10-2.fc23.x86_64
NetworkManager-bluetooth-1.0.10-2.fc23.x86_64
NetworkManager-config-connectivity-fedora-1.0.10-2.fc23.x86_64
NetworkManager-openswan-gnome-1.0.8-1.fc23.x86_64
NetworkManager-vpnc-gnome-1.0.8-1.fc23.x86_64
NetworkManager-vpnc-1.0.8-1.fc23.x86_64
NetworkManager-wifi-1.0.10-2.fc23.x86_64
NetworkManager-iodine-0.0.5-2.fc23.x86_64
NetworkManager-glib-1.0.10-2.fc23.x86_64
NetworkManager-openconnect-1.0.8-1.fc23.x86_64


How reproducible:
It never worked!

Steps to Reproduce:
1. Join user to the dialout group
2. Plugin the usb modem. A PIN request dialog pops up
3. Enter valid TIN
4. USB-Modem accepts tin and led color changes from red to green
5. open the network manager and fill in the well known parameters
6. push connect button
7. the taskbar "donut" for network setup rotates and sometimes disappear.
8. no connection
9. open a shell and call $journalctl -e -a 

 

Actual results:
no connection an some errors in journalctl

Expected results:
established connection

Additional info:

There seems to be an issue with the ttyUSB1 reported by the firewalld:

>> Jan 11 20:57:21 chrissyboy.fritz.box /firewalld[1079]: 2016-01-11 20:57:21 ERROR: UNKNOWN_INTERFACE: 'ttyUSB1' is not in any zone



see output of journalctl (as root)
Jan 11 20:57:14 chrissyboy.fritz.box ModemManager[1086]: <info>  Simple connect started...
Jan 11 20:57:14 chrissyboy.fritz.box ModemManager[1086]: <info>  Simple connect state (4/8): Wait to get fully enabled
Jan 11 20:57:14 chrissyboy.fritz.box ModemManager[1086]: <info>  Simple connect state (5/8): Register
Jan 11 20:57:14 chrissyboy.fritz.box audit[1064]: USER_AVC pid=1064 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } f
                                                   exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'
Jan 11 20:57:14 chrissyboy.fritz.box ModemManager[1086]: <info>  Simple connect state (6/8): Bearer
Jan 11 20:57:14 chrissyboy.fritz.box audit[1064]: USER_AVC pid=1064 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } f
                                                   exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'
Jan 11 20:57:14 chrissyboy.fritz.box ModemManager[1086]: <info>  Simple connect state (7/8): Connect
Jan 11 20:57:14 chrissyboy.fritz.box audit[1064]: USER_AVC pid=1064 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } f
                                                   exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'
Jan 11 20:57:14 chrissyboy.fritz.box ModemManager[1086]: <info>  Modem /org/freedesktop/ModemManager1/Modem/0: state changed (registered -> connecting)
Jan 11 20:57:14 chrissyboy.fritz.box audit[1064]: USER_AVC pid=1064 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } f
                                                   exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'
Jan 11 20:57:14 chrissyboy.fritz.box NetworkManager[1248]: <info>  (ttyUSB1): modem state changed, 'registered' --> 'connecting' (reason: user-requested)
Jan 11 20:57:21 chrissyboy.fritz.box ModemManager[1086]: <warn>  Couldn't initialize PDP context with our APN: 'Sending command failed: 'Resource temporarily unavailable''
Jan 11 20:57:21 chrissyboy.fritz.box ModemManager[1086]: <info>  Modem /org/freedesktop/ModemManager1/Modem/0: state changed (connecting -> registered)
Jan 11 20:57:21 chrissyboy.fritz.box audit[1064]: USER_AVC pid=1064 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } f
                                                   exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <info>  (ttyUSB1): modem state changed, 'connecting' --> 'registered' (reason: user-requested)
Jan 11 20:57:21 chrissyboy.fritz.box audit[1064]: USER_AVC pid=1064 uid=81 auid=4294967295 ses=4294967295 subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { send_msg } f
                                                   exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <warn>  (ttyUSB1): failed to connect modem: Sending command failed: 'Resource temporarily unavailable'
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <info>  (ttyUSB1): device state change: prepare -> failed (reason 'unknown') [40 120 1]
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <info>  NetworkManager state is now CONNECTED_LOCAL
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <info>  Disabling autoconnect for connection '1&1'.
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <warn>  (ttyUSB1): Activation: failed for connection '1&1'
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <info>  (ttyUSB1): device state change: failed -> disconnected (reason 'none') [120 30 0]
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <info>  connectivity: check for uri 'http://fedoraproject.org/static/hotspot.txt' failed with 'Fehler beim Auflösen von »fedoraprojec
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: (gnome-shell:1672): Gjs-WARNING **: JS ERROR: TypeError: this._mobileDevice is null
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: NMDeviceModem<._getSignalIcon@resource:///org/gnome/shell/ui/status/network.js:612
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: NMDeviceModem<.getIndicatorIcon@resource:///org/gnome/shell/ui/status/network.js:605
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: NMConnectionSection<._getMenuIcon@resource:///org/gnome/shell/ui/status/network.js:265
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: NMConnectionSection<._sync@resource:///org/gnome/shell/ui/status/network.js:261
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: _parent@resource:///org/gnome/gjs/modules/lang.js:131
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: NMConnectionDevice<._sync@resource:///org/gnome/shell/ui/status/network.js:441
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: NMConnectionSection<._iconChanged@resource:///org/gnome/shell/ui/status/network.js:250
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Jan 11 20:57:21 chrissyboy.fritz.box /firewalld[1079]: 2016-01-11 20:57:21 ERROR: UNKNOWN_INTERFACE: 'ttyUSB1' is not in any zone
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: (gnome-shell:1672): Gjs-WARNING **: JS ERROR: TypeError: this._activeConnection._connection is null
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: NMConnectionDevice<._activeConnectionChanged@resource:///org/gnome/shell/ui/status/network.js:386
Jan 11 20:57:21 chrissyboy.fritz.box gnome-shell-wayland.desktop[1672]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Jan 11 20:57:29 chrissyboy.fritz.box audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/s
Jan 11 20:57:29 chrissyboy.fritz.box systemd[1]: Starting dnf makecache...
Jan 11 20:57:30 chrissyboy.fritz.box dnf[3353]: cachedir: /var/cache/dnf
Comment 1 Christian Groove 2016-01-12 01:31:11 EST
Dear friends,

other network UI also fail. It is NOT Kde
realted, Gnome and Ciannamon also failed.

Look at the error with the ttyUSB, the error
depends on the unavailability of that device.
This is not KDE related, cause the UI part 
only triggers the Network Manager backend,
and it is the NM-backend part that fails.


The problem may depend on the firewalld, that
tells me, 

>> Jan 11 20:57:21 chrissyboy.fritz.box /firewalld[1079]: 2016-01-11 20:57:21 ERROR: UNKNOWN_INTERFACE: 'ttyUSB1' is not in any zone

that the device it not in any zone. Iff i disable the
firewall, the problem is still there. Some it may
be also possible, that you overseen a setting,
that cause the weired firewalld message.

Send me an message iff i can help you!

Christian
Comment 2 UweR 2016-01-13 02:47:47 EST
I face the same problem.

The problem is that the modem works only if it is connected to ttyUSB0.
The ports ttyUSB1,2 and 3 do not work at all.

Therefore I restart ModemManager and Networkmanager, reconnect the modem and check in /var/log/message if it is connected to ttyUSB0. If not, I restart ModemManager and Networkmanager again. Very tedious procedure.

I think there is a relation to the pin because if I use my Modem abroad with a SIM card without a PIN input everything works out of the box.

So a fix would be great.
Comment 3 Christian Groove 2016-01-14 18:01:00 EST
It looks like to be an Issue of the ModemManager,
there are some similar issues with ZTE ttyUSB 
modems,

lsusb

Bus 001 Device 005: ID 19d2:0117 ZTE WCDMA Technologies MSM
Comment 4 Christian Groove 2016-01-17 15:01:21 EST
I tried to fix it by downgrading the ModemManager to
the version of F21, but i was not successful, i still
get the same errorcode.

After all i reinstalled the usb_modeswitch* that finally
brought to another error of missing parameters. 

Then i installed F22 and the broadband USB stick worked
without any problem. I believe that F23 messed up the
ModemManager with udev and the Networkmanager.

I would be happy to see a solution for that issue before
the F22 runs out of uppdate service.
Comment 5 Lubomir Rintel 2016-07-27 03:22:36 EDT
hmm, this does not look good

Jan 11 20:57:21 chrissyboy.fritz.box ModemManager[1086]: <warn>  Couldn't initialize PDP context with our APN: 'Sending command failed: 'Resource temporarily unavailable''
Jan 11 20:57:21 chrissyboy.fritz.box NetworkManager[1248]: <warn>  (ttyUSB1): failed to connect modem: Sending command failed: 'Resource temporarily unavailable'

I'm wondering if you could retest with the updated packages from here:
https://bodhi.fedoraproject.org/updates/FEDORA-2016-494a721a73

Thank you,
Lubo
Comment 6 Christian Groove 2016-07-27 05:06:59 EDT
The problem disappeared in the meantime for F23, so we can close that issue.
Sorry i have overseen this topic.

Note You need to log in before you can comment on or make changes to this bug.