Bug 1297559 - [RFE] Enhance the installer logs to pull in failures from dependent products
[RFE] Enhance the installer logs to pull in failures from dependent products
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: FutureFeature, UserExperience
: 1306913 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker 1245506
  Show dependency treegraph
 
Reported: 2016-01-11 16:24 EST by Bryan Kearney
Modified: 2018-05-03 13:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-03 13:34:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16939 None None None 2016-10-14 09:49 EDT

  None (edit)
Description Bryan Kearney 2016-01-11 16:24:56 EST
See https://bugzilla.redhat.com/show_bug.cgi?id=1245506. 3 of the Issues deal with pulling failures from dependent log files into the installer:

Issue 3:
How to pull in log files from postgresql not starting

Issue 4:
How to pull in log files from mongo not starting.

Issue 5:
How to pull in log files from qpidd.
Comment 2 Stephen Benjamin 2016-10-14 09:49:35 EDT
If the installer notes a mongo failure, it's pretty typical the user should have to go to the mongo log to look and see why. 

We would likely need to add something to service-wait resource puppet provider and tell it where particular service logs are, and then have it extract the last N lines.
Comment 3 Stephen Benjamin 2016-10-14 09:49:54 EDT
Created redmine issue http://projects.theforeman.org/issues/16939 from this bug
Comment 4 Stephen Benjamin 2016-10-14 10:47:25 EDT
*** Bug 1306913 has been marked as a duplicate of this bug. ***
Comment 5 Bryan Kearney 2018-05-03 13:34:14 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.