Bug 1297573 - Upgrade from latest oVirt 3.5 to 3.6 missing file pki-ssh-keygen.py
Upgrade from latest oVirt 3.5 to 3.6 missing file pki-ssh-keygen.py
Status: CLOSED NOTABUG
Product: otopi
Classification: oVirt
Component: Bindings.Python (Show other bugs)
master
x86_64 Linux
unspecified Severity low (vote)
: ---
: ---
Assigned To: Yedidyah Bar David
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 17:26 EST by Andreas Huser
Modified: 2017-01-23 07:57 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 04:46:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Andreas Huser 2016-01-11 17:26:01 EST
Description of problem:

Hi, i try an upgrade from oVirt 3.5 (latest) to version 3.6.
Moment during the engine-setup i a mistake:

Red Hat Enterprise Linux Server release 7.2 (Maipo)
oVirt:
Name        : ovirt-engine
Architektur : noarch
Version     : 3.5.3.1


[ INFO  ] Upgrading CA
[ ERROR ] Failed to execute stage 'Misc configuration': [Errno 2] Datei oder Verzeichnis nicht gefunden
[ INFO  ] Rolling back database schema
[ INFO  ] Clearing Engine database engine
[ INFO  ] Restoring Engine database engine
[ INFO  ] Restoring file '/var/lib/ovirt-engine/backups/engine-20160111230756.WSBbCp.dump' to database localhost:engine.
[ ERROR ] Errors while restoring engine database, please check the log file for details
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20160111230730-6cw5nu.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20160111230820-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Additional info:

I found in the logfile the error missing file "pki-ssh-keygen.py" 
I raided the server for the file. Have they not found

I try it upgrade to 3.6-snapshot, with same result. 

2016-01-11 21:36:34 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.pki.ssh plugin.executeRaw:828 execute: ('/usr/share/ovirt-engine/bin/pki-ssh-keygen.py', '-l', '-i', '-m',
 'PKCS8', '-f', '/proc/self/fd/0'), executable='None', cwd='None', env=None
2016-01-11 21:36:34 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.pki.ssh plugin.executeRaw:884 execute-result: ('/usr/share/ovirt-engine/bin/pki-ssh-keygen.py', '-l', '-i'
, '-m', 'PKCS8', '-f', '/proc/self/fd/0'), exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/plugin.py", line 871, in executeRaw
    preexec_fn=preexec_fn,
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden
2016-01-11 21:36:34 DEBUG otopi.context context._executeMethod:156 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 146, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/pki/ssh.py", line 120, in _misc
    ] = self._getSSHPublicKey(self._getEnginePublicKey())
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/pki/ssh.py", line 51, in _getSSHPublicKey
    stdin=key.split('\n'),
 packet_write_wait: Connection to 10.0.10.129: Broken pipe line 927, in execute
Andreass-MBP:tftpboot ahuser$ 
Andreass-MBP:tftpboot ahuser$ ssh -l root kvmsrv01 
Andreass-MBP:tftpboot ahuser$ 
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden
2016-01-11 21:36:34 ERROR otopi.context context._executeMethod:165 Failed to execute stage 'Misc configuration': [Errno 2] Datei oder Verzeichnis nicht gefunden
2016-01-11 21:36:34 DEBUG otopi.transaction transaction.abort:134 aborting 'Database Transaction'

Regards Andreas
Comment 1 Andreas Huser 2016-01-12 01:28:37 EST
Is it true that you have only one package from the old version?
Should there not also the new package from the repo 3.6 be?

[root@kvmsrv01 ~]# yum info ovirt-engine
Geladene Plugins: langpacks, ulninfo, versionlock
Installierte Pakete
Name       : ovirt-engine
Architektur : noarch
Version    : 3.5.3.1
Ausgabe    : 1.el7.centos
Größe : 2.3 M
Quelle      : installed
Aus Quelle  : ovirt-3.5
Zusammenfassung: Management server for Open Virtualization
URL        : http://www.ovirt.org
Lizenz      : ASL 2.0
Comment 2 Andreas Huser 2016-01-13 02:18:23 EST
Hi, have i resolved the problem.

i have removed all packages and installed ovirt 3.5 again. Then can i upgrade to 3.6 without errors. 

Regards
Comment 3 Yedidyah Bar David 2016-01-13 03:35:59 EST
pki-ssh-keygen.py was added [1] during 3.6 development, to overcome a limitation of the openssh version in el6.

It was never included in any 3.5 version.

It was also removed [2] in master branch (to become 4.0), which no longer supports el6.

If you still have the machine, please attach all setup logs and yum logs:

/var/log/ovirt-engine-setup/*
/var/log/yum.log*

Please also detail the flow. What was the initial version installed, what was it upgraded to over time, and especially whether you did any custom changes etc. except for normal upgrades.

Thanks.

[1] https://gerrit.ovirt.org/38092
[2] https://gerrit.ovirt.org/45701
Comment 4 Sandro Bonazzola 2016-01-14 04:46:13 EST
(In reply to Andreas Huser from comment #2)
> Hi, have i resolved the problem.
> 
> i have removed all packages and installed ovirt 3.5 again. Then can i
> upgrade to 3.6 without errors. 


Closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.