Bug 1297590 - Missing text, if set --timeout switch
Missing text, if set --timeout switch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yad (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Elder Marco
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 18:36 EST by rvcsaba
Modified: 2016-01-13 05:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 05:01:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yat with timeout (1.90 KB, image/png)
2016-01-12 07:18 EST, rvcsaba
no flags Details
yad without timeout (1.82 KB, image/png)
2016-01-12 07:19 EST, rvcsaba
no flags Details

  None (edit)
Description rvcsaba 2016-01-11 18:36:15 EST
Description of problem:

I updated yad from koji build server.

yad --title='Title' --button 'Button:0' --text='Hello' --width=150 --height=80

work, text show, but

yad --title='Title' --button 'Button:0' --text='Hello' --width=150 --height=80 --timeout=5

I can't show text.


Version-Release number of selected component (if applicable):

yad-0.33.0-1.fc23.x86_64


How reproducible:

Please see description!


Steps to Reproduce:

Test without or with --timeout parameter.


Actual results:

If I use --timeout parameter, --text hidden.


Expected results:

Independently --timeout parameter, show --text.
Comment 1 Oliver Haessler 2016-01-12 06:53:17 EST
I have tried it with yad-0.33.0-1.el7.x86_64 and can not reproduce the error.

The only error I have is, that the --timeout parameter is not working as expected. You need to add --timeout-indicator to make the timeout parameter work. This is already fixed in 0.33.1


yad-0.33.1-1 is already in the process to be pushed to testing. Can you please test it again and let me know.

https://bodhi.fedoraproject.org/updates/FEDORA-2016-be70fd0644

Thanks
Oliver
Comment 2 rvcsaba 2016-01-12 07:17:04 EST
I updated yad from koji:

rpm -q yad
yad-0.33.1-1.fc23.x86_64

I tested it, but wrong. :(

yad_with_timeout.png:

yad --title='Title' --button 'Button:0' --text='Hello' --width=150 --height=80 --timeout=5


yad_without_timeout.png:

yad --title='Title' --button 'Button:0' --text='Hello' --width=150 --height=80


(Sorry my very poor english.)

(In reply to Oliver Haessler from comment #1)
> yad-0.33.1-1 is already in the process to be pushed to testing. Can you
> please test it again and let me know.

> Thanks
> Oliver
Comment 3 rvcsaba 2016-01-12 07:18 EST
Created attachment 1113918 [details]
yat with timeout

yad --title='Title' --button 'Button:0' --text='Hello' --width=150 --height=80 --timeout=5
Comment 4 rvcsaba 2016-01-12 07:19 EST
Created attachment 1113919 [details]
yad without timeout

yad --title='Title' --button 'Button:0' --text='Hello' --width=150 --height=80
Comment 5 rvcsaba 2016-01-12 07:34:23 EST
yad-0.32.0-1.fc23.x86_64 work correctly.

Only 0.33.0 and 0.33.1 wrong. I tested it.
Comment 6 Oliver Haessler 2016-01-12 10:45:28 EST
Hi have contacted the developer here: https://groups.google.com/forum/#!topic/yad-common/kue2i5YupRc to let him know about this bug.

Cheers
Oliver
Comment 7 rvcsaba 2016-01-13 04:59:03 EST
Victor Ananjevsky wrote:

delete yad config file ($XDG_CONFIG_HOME/yad.conf)

I update to yad-0.33.1-1.fc23.x86_64, deleted $HOME/.config/yad.conf and tested it. Work correctly.

Thanks!
Comment 8 Oliver Haessler 2016-01-13 05:01:32 EST
solved by deleting the yad.conf file in $HOME/.config/yad.conf

Note You need to log in before you can comment on or make changes to this bug.