This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297630 - [abrt] Thunar: thunar_shortcuts_model_set_busy(): thunar killed by SIGSEGV
[abrt] Thunar: thunar_shortcuts_model_set_busy(): thunar killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:26c5c3a5ef6917bd26779d8cd71...
:
: 1390850 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 23:21 EST by Jeff Sites
Modified: 2017-02-25 20:35 EST (History)
6 users (show)

See Also:
Fixed In Version: Thunar-1.6.11-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-25 20:35:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (33.69 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: cgroup (242 bytes, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: core_backtrace (5.64 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: dso_list (10.50 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: environ (1.94 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: maps (54.45 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: mountinfo (3.43 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: namespaces (85 bytes, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: open_fds (1.13 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: proc_pid_status (1.17 KB, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-01-11 23:21 EST, Jeff Sites
no flags Details

  None (edit)
Description Jeff Sites 2016-01-11 23:21:22 EST
Description of problem:
Following attempted repro of Bug 1297224, when closing the file manager window, SIGSEGV generated

https://bugzilla.redhat.com/show_bug.cgi?id=1297224

Version-Release number of selected component:
Thunar-1.6.10-4.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/Thunar
crash_function: thunar_shortcuts_model_set_busy
executable:     /usr/bin/thunar
global_pid:     4054
kernel:         4.4.0-0.rc8.git3.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 thunar_shortcuts_model_set_busy at thunar-shortcuts-model.c:2163
 #1 thunar_shortcuts_view_eject_finish at thunar-shortcuts-view.c:1885
 #2 thunar_device_operation_finish at thunar-device.c:275
 #3 g_simple_async_result_complete at gsimpleasyncresult.c:801
 #4 eject_cb at gproxydrive.c:599
 #5 g_task_return_now at gtask.c:1107
 #6 g_task_return at gtask.c:1165
 #7 reply_cb at gdbusproxy.c:2580
 #8 g_task_return_now at gtask.c:1107
 #9 g_task_return at gtask.c:1165

Potential duplicate: bug 915430
Comment 1 Jeff Sites 2016-01-11 23:21:27 EST
Created attachment 1113824 [details]
File: backtrace
Comment 2 Jeff Sites 2016-01-11 23:21:28 EST
Created attachment 1113825 [details]
File: cgroup
Comment 3 Jeff Sites 2016-01-11 23:21:29 EST
Created attachment 1113826 [details]
File: core_backtrace
Comment 4 Jeff Sites 2016-01-11 23:21:30 EST
Created attachment 1113827 [details]
File: dso_list
Comment 5 Jeff Sites 2016-01-11 23:21:32 EST
Created attachment 1113828 [details]
File: environ
Comment 6 Jeff Sites 2016-01-11 23:21:33 EST
Created attachment 1113829 [details]
File: limits
Comment 7 Jeff Sites 2016-01-11 23:21:34 EST
Created attachment 1113830 [details]
File: maps
Comment 8 Jeff Sites 2016-01-11 23:21:36 EST
Created attachment 1113831 [details]
File: mountinfo
Comment 9 Jeff Sites 2016-01-11 23:21:37 EST
Created attachment 1113832 [details]
File: namespaces
Comment 10 Jeff Sites 2016-01-11 23:21:38 EST
Created attachment 1113833 [details]
File: open_fds
Comment 11 Jeff Sites 2016-01-11 23:21:39 EST
Created attachment 1113834 [details]
File: proc_pid_status
Comment 12 Jeff Sites 2016-01-11 23:21:40 EST
Created attachment 1113835 [details]
File: var_log_messages
Comment 13 Jeff Sites 2016-01-11 23:30:11 EST
Meant to attach the stack trace to https://bugzilla.redhat.com/show_bug.cgi?id=1297224 but the offending function appears to be unique here
Comment 14 Mukundan Ragavan 2016-01-12 17:10:22 EST
This does seem to be a different problem from thunar copy/paste grievance.
Comment 15 Jan Kurik 2016-02-24 09:15:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 16 r415312 2016-11-02 02:00:54 EDT
*** Bug 1390850 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2017-02-14 22:14:45 EST
Thunar-1.6.11-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9b303854c7
Comment 18 Fedora Update System 2017-02-17 10:24:41 EST
Thunar-1.6.11-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9b303854c7
Comment 19 Fedora Update System 2017-02-25 20:35:36 EST
Thunar-1.6.11-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.