Bug 1297639 - unwanted update of keepassx requires one-way database conversion
unwanted update of keepassx requires one-way database conversion
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: keepassx (Show other bugs)
23
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 00:14 EST by Robert Story
Modified: 2016-04-18 13:26 EDT (History)
8 users (show)

See Also:
Fixed In Version: keepassx-0.4.4-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 13:26:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Story 2016-01-12 00:14:32 EST
Description of problem:
keepassx update requires one way conversion of v1 databases

Version-Release number of selected component (if applicable):
2.0.0-1

How reproducible:
always

Steps to Reproduce:
1. start keepassx
2. try to open v1 database
3.

Actual results:
an option to perform a one-way conversion is offered

Expected results:
that an application that worked with my v1 database yesterday would work today.

Additional info:
I sync my database between multiple devices, some of which have no option for reading v2 databases.
Comment 1 Ed Marshall 2016-01-12 04:12:00 EST
This seems like it was far too aggressive an update for mid-release? Would this not have been better to do with F24? This breaks anyone needing to maintain compatibility with keepass 1.x databases, mid-release.
Comment 2 Tim Hughes 2016-02-17 05:16:36 EST
Can we get this package removed and renamed keepassx2 or the other way and call it keepassx1 - this is breaking change mid release. 

We share this database with multiple staff some of which use centos desktop and other distros.
Comment 3 Tim Hughes 2016-02-17 05:17:10 EST
see https://bugzilla.redhat.com/show_bug.cgi?id=1147928#c7
Comment 4 Tim Hughes 2016-02-17 06:57:49 EST
Looks like this isnt going to happen https://bugzilla.redhat.com/show_bug.cgi?id=1282825
Comment 5 Fedora Update System 2016-04-13 10:29:41 EDT
keepassx-0.4.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e57f60ec84
Comment 6 Fedora Update System 2016-04-13 10:29:50 EDT
keepassx-0.4.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0517fab538
Comment 7 Fedora Update System 2016-04-13 10:29:56 EDT
keepassx-0.4.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-139a37787e
Comment 8 Gwyn Ciesla 2016-04-13 10:30:29 EDT
I'm working on keepassx2, I'll post when it's ready for review.
Comment 9 Gwyn Ciesla 2016-04-13 11:34:08 EDT
Review submitted:

https://bugzilla.redhat.com/show_bug.cgi?id=1326875
Comment 10 Fedora Update System 2016-04-15 04:38:39 EDT
keepassx-0.4.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-139a37787e
Comment 11 Fedora Update System 2016-04-16 15:27:32 EDT
keepassx-0.4.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e57f60ec84
Comment 12 Fedora Update System 2016-04-16 15:28:27 EDT
keepassx-0.4.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0517fab538
Comment 13 srakitnican 2016-04-16 17:33:35 EDT
I started using new database format which this update broke, also not nice :)

Could we have keepassx2 package?
Comment 14 Gwyn Ciesla 2016-04-17 10:00:57 EDT
I submitted it for review:

https://bugzilla.redhat.com/show_bug.cgi?id=1326875

If you need an unofficial build, please let me know the release and arch, or you can build from the SRPM in the review.
Comment 15 srakitnican 2016-04-17 18:50:20 EDT
I have downgraded to 2.0.0 and blacklisted 0.4.4 in dnf for now, thanks.
Comment 16 Fedora Update System 2016-04-18 13:26:15 EDT
keepassx-0.4.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.