This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 129764 - disk-druid crashes trying to edit pre-existing partitions
disk-druid crashes trying to edit pre-existing partitions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-12 11:58 EDT by G.Wolfe Woodbury
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-14 13:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda crash dump (56.97 KB, text/plain)
2004-08-12 12:00 EDT, G.Wolfe Woodbury
no flags Details

  None (edit)
Description G.Wolfe Woodbury 2004-08-12 11:58:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Anaconda/disk-druid fails with an unhandled exception when trying to
edit pre-existing partitions to reset the mount point and formatting
options.

Version-Release number of selected component (if applicable):
anaconda-10.0.2-0.20040811223028.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.make boot.iso from 2004-08-12 rawhide
2.boot, select fresh install
3.select "custom" install
4.select "use disk-druid"
5.attempt to edit a pre-existing partition to set it's mount point

Actual Results:  exception dump - see attachment

Expected Results:  allowed to set (e.g. /boot) mount point and format
options

Additional info:
Comment 1 G.Wolfe Woodbury 2004-08-12 12:00:18 EDT
Created attachment 102653 [details]
anaconda crash dump
Comment 2 G.Wolfe Woodbury 2004-08-12 12:02:33 EDT
machine is AMD-K6/2 at 380MHz
Asus P5AB motherboard
IDE drives and CD-ROM, etc.
Comment 3 Jeremy Katz 2004-08-12 18:54:15 EDT
Think this is fixed in CVS.  Could you retry with rawhide tomorrow to
verify?
Comment 4 G.Wolfe Woodbury 2004-08-14 00:44:00 EDT
seems to be fixed in 2004-08-12 rawhide
Comment 5 Jeremy Katz 2004-08-14 13:05:32 EDT
Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.