Bug 1297659 - [DOCS] Creating-image-streams-for-xpaas-middleware-images
[DOCS] Creating-image-streams-for-xpaas-middleware-images
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Misha H. Ali
Vikram Goyal
Vikram Goyal
:
Depends On: 1300503
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 02:22 EST by Libor Fuka
Modified: 2016-07-13 20:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-13 20:16:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Fuka 2016-01-12 02:22:11 EST
Description of problem:
I read documentation for xPaas and found something which i haven't understood:
https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/installation-and-configuration/#creating-image-streams-for-xpaas-middleware-images

Chapter 2.7.2. Prerequisites
 - You must be able to run the following CLI commands with cluster-admin privileges, because they operate on the default openshiftproject.

Its not clear which CLI commands. Do you mean CLI commands oc create in next chapters ?
I think there should be better to somehow rephrase this sentence to be more clear which CLI commands.

Version-Release number of selected component (if applicable):
OSv3.1/xPaaS documentation

Document URL:
https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/installation-and-configuration/#creating-image-streams-for-xpaas-middleware-images

Section Number and Name: 
Chapter 2.7.2. Prerequisites
Comment 1 Misha H. Ali 2016-02-22 19:53:27 EST
Vikram indicated that Timothy would be the correct person to clarify which CLI commands were intended to be listed here, so setting a NEEDINFO for him.
Comment 2 Timothy 2016-02-22 20:22:24 EST
"You must be able to run the following CLI commands with cluster-admin privileges, because they operate on the default openshift project."

^ the above applies to all the sections in that topic:

2.8.3. Creating Image Streams for OpenShift Images
2.8.4. Creating Image Streams for xPaaS Middleware Images
2.8.5. Creating Database Service Templates
2.8.6. Creating InstantApp Templates

All the oc create commands require cluster-admin privileges.

However, the content relevant to this BZ is being moved significantly by the following PR:

https://github.com/openshift/openshift-docs/pull/1536
https://bugzilla.redhat.com/show_bug.cgi?id=1300503

For that reason, this BZ should wait until that PR merges before continuing.
Comment 3 Misha H. Ali 2016-03-22 02:17:06 EDT
* Changed line to specify that oc create is the command that requires the stated privileges.

* Created PR: https://github.com/openshift/openshift-docs/pull/1782

* Asked tpoitras to review
Comment 4 Vikram Goyal 2016-07-13 20:16:31 EDT
Live here: https://docs.openshift.com/enterprise/3.1/install_config/imagestreams_templates.html

Moving this bug to CLOSED-->CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.