Bug 1297672 - [RHEV-Beta] Dependency issue with ovirt-hosted-engine-setup
[RHEV-Beta] Dependency issue with ovirt-hosted-engine-setup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.6.0
x86_64 Linux
high Severity high
: ovirt-3.6.1
: ---
Assigned To: Joey Boggs
Nikolai Sednev
: Triaged
Depends On:
Blocks: RHEV_36_HTB
  Show dependency treegraph
 
Reported: 2016-01-12 02:52 EST by Martin Tessun
Modified: 2016-05-23 07:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:34:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Rel-Eng
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Tessun 2016-01-12 02:52:42 EST
Description of problem:
Installation of ovirt-hosted-engine-setup fails due to dependency problems

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.3.1.4-1.el7ev.noarch

How reproducible:
always

Steps to Reproduce:
1. yum install ovirt-hosted-engine-setup

Actual results:
Fails with dependency issue:

[root@rhevhb1 ~]# yum install ovirt-hosted-engine-setup 
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Resolving Dependencies
--> Running transaction check
---> Package ovirt-hosted-engine-setup.noarch 0:1.3.1.4-1.el7ev will be installed
--> Processing Dependency: ovirt-hosted-engine-ha >= 1.3.3.6 for package: ovirt-hosted-engine-setup-1.3.1.4-1.el7ev.noarch
[...]
--> Finished Dependency Resolution
Error: Package: ovirt-hosted-engine-setup-1.3.1.4-1.el7ev.noarch (rhel-x86_64-rhev-mgmt-agent-7-beta)
           Requires: ovirt-hosted-engine-ha >= 1.3.3.6
           Available: ovirt-hosted-engine-ha-1.2.4-1.el7.noarch (rhel-x86_64-rhev-mgmt-agent-7-beta)
               ovirt-hosted-engine-ha = 1.2.4-1.el7
           Available: ovirt-hosted-engine-ha-1.2.4-5.el7ev.noarch (rhel-x86_64-rhev-mgmt-agent-7-beta)
               ovirt-hosted-engine-ha = 1.2.4-5.el7ev
           Available: ovirt-hosted-engine-ha-1.3.2.1-1.el7ev.noarch (rhel-x86_64-rhev-mgmt-agent-7-beta)
               ovirt-hosted-engine-ha = 1.3.2.1-1.el7ev
           Available: ovirt-hosted-engine-ha-1.3.3.3-1.el7ev.noarch (rhel-x86_64-rhev-mgmt-agent-7-beta)
               ovirt-hosted-engine-ha = 1.3.3.3-1.el7ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@rhevhb1 ~]# yum list ovirt-hosted-engine-ha --show-duplicates
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Available Packages
ovirt-hosted-engine-ha.noarch                      1.2.4-1.el7                           rhel-x86_64-rhev-mgmt-agent-7-beta
ovirt-hosted-engine-ha.noarch                      1.2.4-5.el7ev                         rhel-x86_64-rhev-mgmt-agent-7-beta
ovirt-hosted-engine-ha.noarch                      1.3.2.1-1.el7ev                       rhel-x86_64-rhev-mgmt-agent-7-beta
ovirt-hosted-engine-ha.noarch                      1.3.3.3-1.el7ev                       rhel-x86_64-rhev-mgmt-agent-7-beta
[root@rhevhb1 ~]# 


Expected results:
Dependencies should be resolved correctly.


Additional info:
Also CDN does not show the 1.3.3.6 package. The test itself was done with Satellite 5 channels.
Comment 1 Martin Tessun 2016-01-12 03:05:11 EST
yum install ovirt-hosted-engine-setup-1.3.1.3-1.el7ev does work, which is the previous release:

[root@rhevhb1 ~]# yum list ovirt-hosted-engine-setup --showduplicates
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Available Packages
ovirt-hosted-engine-setup.noarch     1.2.1-3.el7ev     rhel-x86_64-rhev-mgmt-agent-7-beta
ovirt-hosted-engine-setup.noarch     1.2.1-8.el7ev     rhel-x86_64-rhev-mgmt-agent-7-beta
ovirt-hosted-engine-setup.noarch     1.3.0-1.el7ev     rhel-x86_64-rhev-mgmt-agent-7-beta
ovirt-hosted-engine-setup.noarch     1.3.1.3-1.el7ev   rhel-x86_64-rhev-mgmt-agent-7-beta
ovirt-hosted-engine-setup.noarch     1.3.1.4-1.el7ev   rhel-x86_64-rhev-mgmt-agent-7-beta
[root@rhevhb1 ~]#
Comment 2 Sandro Bonazzola 2016-01-12 05:11:52 EST
Joey, can you check why ovirt-hosted-engine-ha-1.3.3.6-1.el7ev has not been pushed to the channel?
Comment 6 Nikolai Sednev 2016-01-21 05:35:21 EST
Successfully got HE packages installed on clean OS and deployed it over NFS Engine was installed using PXE.
Works for me on these components:
Host:
ovirt-vmconsole-1.0.0-1.el7ev.noarch
ovirt-hosted-engine-ha-1.3.3.7-1.el7ev.noarch
mom-0.5.1-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.6.x86_64
ovirt-host-deploy-1.4.1-1.el7ev.noarch
libvirt-client-1.2.17-13.el7_2.2.x86_64
ovirt-setup-lib-1.0.1-1.el7ev.noarch
vdsm-4.17.18-0.el7ev.noarch
ovirt-vmconsole-host-1.0.0-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.2.3-1.el7ev.noarch
sanlock-3.2.4-2.el7_2.x86_64
Linux version 3.10.0-327.8.1.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Mon Jan 11 05:03:18 EST 2016

Engine:
ovirt-vmconsole-1.0.0-1.el6ev.noarch
ovirt-host-deploy-1.4.1-1.el6ev.noarch
ovirt-setup-lib-1.0.1-1.el6ev.noarch
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
ovirt-host-deploy-java-1.4.1-1.el6ev.noarch
ovirt-engine-extension-aaa-jdbc-1.0.5-1.el6ev.noarch
rhevm-3.6.2.6-0.1.el6.noarch
rhevm-dwh-setup-3.6.2-1.el6ev.noarch
rhevm-dwh-3.6.2-1.el6ev.noarch
rhevm-reports-setup-3.6.2.4-1.el6ev.noarch
rhevm-reports-3.6.2.4-1.el6ev.noarch
rhevm-guest-agent-common-1.0.11-2.el6ev.noarch
Linux version 2.6.32-573.8.1.el6.x86_64 
(mockbuild@x86-033.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-16) (GCC) ) #1 SMP Fri Sep 25 19:24:22 EDT 2015

Note You need to log in before you can comment on or make changes to this bug.