Bug 1297689 - No error message is shown on getDevicelist failure when adding a new FC storage domain
No error message is shown on getDevicelist failure when adding a new FC stora...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.Core (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Idan Shaby
Elad
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 03:56 EST by Idan Shaby
Modified: 2016-07-05 04:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 04:02:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
tnisan: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51720 master MERGED frontend: fix FcpStorageView faults 2016-01-13 11:29 EST

  None (edit)
Description Idan Shaby 2016-01-12 03:56:53 EST
Description of problem:
When trying to add a storage domain of the type Fibre channel, if the connection to the FC host is blocked and getDeviceList fails, no luns are loaded to the view but also no error message is shown to the user, causing a false understanding that no luns actually exist.

Version-Release number of selected component (if applicable):
75b745189ee54a7d3cf80102716d5292c9f7d033

How reproducible:
100%

Steps to Reproduce:
1. Open the New Domain window in the webadmin.
2. Choose a FC host.
3. Block the connection between the engine and the FC host.
4. Set the Storage Type to Fibre Channel.

Actual results:
The process is stuck for a while (about 40-50 seconds on my env) since getDeviceList doesn't end.
When it fails, no luns are loaded to the view, and no error message is shown to the user.


Expected results:
An error message should be shown.

Additional info:
Comment 1 Elad 2016-04-19 03:44:50 EDT
In a DC with a host exposed to FC, initiated storage domain creation via Webadmin, blocked connectivity between the engine and the host using iptables, picked FC in the domain creation prompt.

Domain creation prompt gets stuck for ~1 minute due to a failure in GetDeviceList [1] and then the following error message is presented in Webadmin:



" Could not retrieve LUNs, please check your storage. "




[1]

2016-04-19 09:55:16,490 ERROR [org.ovirt.engine.core.bll.storage.disk.lun.GetDeviceListQuery] (default task-4) [] Exception: org.ovirt.engine.core.common.errors.EngineException: EngineEx
ception: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSNetworkException: VDSGenericException: VDSNetworkException: Heartbeat exeeded (Failed with error VDS_NETWORK_ERROR and code 5022)
        at org.ovirt.engine.core.bll.VdsHandler.handleVdsResult(VdsHandler.java:114) [bll.jar:]
        at org.ovirt.engine.core.bll.VDSBrokerFrontendImpl.runVdsCommand(VDSBrokerFrontendImpl.java:33) [bll.jar:]
        at org.ovirt.engine.core.bll.QueriesCommandBase.runVdsCommand(QueriesCommandBase.java:254) [bll.jar:]
        at org.ovirt.engine.core.bll.storage.disk.lun.GetDeviceListQuery.executeQueryCommand(GetDeviceListQuery.java:29) [bll.jar:]




Verified using:
ovirt-engine-4.0.0-0.0.master.20160406161747.gita4ecba2.el7.centos.noarch
ovirt-engine-webadmin-portal-4.0.0-0.0.master.20160406161747.gita4ecba2.el7.centos.noarch
vdsm-4.17.999-724.gitb8cb30a.el7.centos.noarch
Comment 2 Sandro Bonazzola 2016-07-05 04:02:17 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.