Bug 129769 - Makefile in new python conflicts with older version found in old python-devel
Summary: Makefile in new python conflicts with older version found in old python-devel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-12 16:17 UTC by Jeff Pitman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-01 01:17:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Pitman 2004-08-12 16:17:05 UTC
Description of problem:

Because of distutils the Makefile was moved from -devel into the main
package, but this will cause a Conflict if a python-devel=2.3.3 exists
when doing a straight install of python (yum install;apt-get install)
without installing python-devel.

Version-Release number of selected component (if applicable):

2.3.4-7

Steps to Reproduce:
1. Have distro with python, python-devel=2.3.3 installed.
2. yum install or apt-get install python.

  
Actual results:
Conflicts on the config/Makefile


Expected results:
Successful resolution


Additional info:

Probably something like this is need in the SPEC
# Makefile now in main pkg for distutils
Conflicts: python-devel < %{version}

Comment 1 Mihai Ibanescu 2004-08-13 17:31:53 UTC
Heh, lovely.

Comment 2 Mihai Ibanescu 2004-08-19 14:17:48 UTC
Should be fixed in python 2.3.4-8


Note You need to log in before you can comment on or make changes to this bug.