Bug 1297712 - PackStack misconfigures lvm.conf
PackStack misconfigures lvm.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Javier Peña
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 04:57 EST by Marko Myllynen
Modified: 2016-05-16 03:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-packstack-7.0.0-0.11.dev1692.g1b5e83b.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, Packstack edited the /etc/lvm/lvm.conf file to set specific parameters for snapshot autoextend. However, the regexp used only allowed blank spaces instead of the tabs as currently used in the file. As a result, some lines were added at the end of the file, breaking its format. With this update, the regexp is updated in Packstack to set the parameters properly. As a result, there are no error messages when running LVM commands.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:21:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 269696 None None None 2016-01-19 10:06 EST

  None (edit)
Description Marko Myllynen 2016-01-12 04:57:03 EST
Description of problem:
# pvck
# packstack ...
# pvck
  Configuration setting "snapshot_autoextend_percent" invalid. It's not part of any section.
  Configuration setting "snapshot_autoextend_threshold" invalid. It's not part of any section.
# tail -n 2 /etc/lvm/lvm.conf
  snapshot_autoextend_threshold = 80
  snapshot_autoextend_percent = 20
Comment 2 Javier Peña 2016-01-19 10:06:27 EST
Proposed fix at https://review.openstack.org/269696
Comment 5 cappetta 2016-03-12 09:13:15 EST
Hitting this issue... looking for / researching a work around...
Comment 6 cappetta 2016-03-12 09:22:35 EST
Looks like I had these 2 parameters set 2x.  deleted the last 2 at the end of the file and believe all is good.
Comment 7 errata-xmlrpc 2016-04-07 17:21:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.