Bug 1297733 - No VPN tab in Horizon after deploy OSP-8 with packstack - CONFIG_NEUTRON_VPNAAS=y
No VPN tab in Horizon after deploy OSP-8 with packstack - CONFIG_NEUTRON_VPNA...
Status: CLOSED UPSTREAM
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: Javier Peña
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 05:39 EST by Eran Kuris
Modified: 2016-04-18 03:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 12:48:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 269617 None None None 2016-01-19 08:09 EST

  None (edit)
Description Eran Kuris 2016-01-12 05:39:21 EST
Description of problem:
Deploy with latest packstack version OSP-8 and enabled VPNaaS in answer file 
CONFIG_NEUTRON_VPNAAS=y
deploy succuessful but there is no VPN tab in horizon .
The reason is packstack didnt change in :
/usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py

this parameter to "TRUE" 
OPENSTACK_NEUTRON_NETWORK = {
    'enable_distributed_router': False,
    'enable_firewall': False,
    'enable_ha_router': False,
    'enable_lb': False,
    'enable_quotas': True,
    'enable_security_group': True,
    'enable_vpn': False  <----------- this parameter should be change to True  
    'profile_support': 'None',
}


Version-Release number of selected component (if applicable):
# rpm -qa |grep vpn
python-neutron-vpnaas-7.0.0-1.el7ost.noarch
openstack-neutron-vpnaas-7.0.0-1.el7ost.noarch
[root@rose12 ~(keystone_admin)]# rpm -qa |grep  packstack
openstack-packstack-7.0.0-0.8.dev1661.gaf13b7e.el7ost.noarch
openstack-packstack-puppet-7.0.0-0.8.dev1661.gaf13b7e.el7ost.noarch
[root@rose12 ~(keystone_admin)]# rpm -qa |grep  neutron
python-neutronclient-3.1.0-1.el7ost.noarch
python-neutron-7.0.1-2.el7ost.noarch
openstack-neutron-common-7.0.1-2.el7ost.noarch
openstack-neutron-7.0.1-2.el7ost.noarch
openstack-neutron-ml2-7.0.1-2.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-2.el7ost.noarch
python-neutron-vpnaas-7.0.0-1.el7ost.noarch
openstack-neutron-vpnaas-7.0.0-1.el7ost.noarch


How reproducible:
always
Steps to Reproduce:
1.Install OSP-8 with packstack , set VPNAAS = y 
2.after installation finish enter to horizon - no VPN tab 
3./usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py 
vpn is in false

Actual results:


Expected results:


Additional info:
Comment 2 Javier Peña 2016-01-19 08:09:57 EST
Proposed https://review.openstack.org/269617 with a fix.

Note You need to log in before you can comment on or make changes to this bug.