Bug 1297751 - Graphics protocol of VM sometimes disappears when changed
Graphics protocol of VM sometimes disappears when changed
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.2
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: jniederm
Ilanit Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 06:50 EST by jniederm
Modified: 2016-02-18 06:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Sometimes graphical protocol (SPICE, VNC) may be lost if edited in Edit VM dialog > Console tab. Fix: Graphical protocols are presisted. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:13:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: planning_ack+
michal.skrivanek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
graphical protocol none (14.72 KB, image/png)
2016-01-12 06:50 EST, jniederm
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51714 master MERGED core: Losing graphical protocol fix 2016-01-13 06:43 EST
oVirt gerrit 51715 ovirt-engine-3.6 MERGED core: Losing graphical protocol fix 2016-01-13 10:20 EST

  None (edit)
Description jniederm 2016-01-12 06:50:02 EST
Created attachment 1113911 [details]
graphical protocol none

Description of problem:
Graphical protocol of VM sometimes removed when changed.

Version-Release number of selected component (if applicable):
3.6.3_master (commit 3b332fb)

How reproducible:
50%, optionally repeat step 4 multiple times

Steps to Reproduce:
1. Create Data Center, level 3.5
2. Create Cluster, level 3.5
3. Create new VM in cluster above
4. Edit the VM, change Console > Graphics Protocol (VNC <-> SPICE), confirm edit dialog

Actual results:
Sometimes (mostly with change VNC -> SPICE) the graphical protocol is completely removed. See screenshot.

Expected results:
Selected protocol is saved.
Comment 1 Red Hat Bugzilla Rules Engine 2016-01-12 07:34:59 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2016-01-12 07:36:10 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 3 Ilanit Stein 2016-02-09 07:17:20 EST
Verified on rhevm 3.6.3-0.1

Note You need to log in before you can comment on or make changes to this bug.