Bug 1297757 - Increase start timeout for systemd hook
Increase start timeout for systemd hook
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Matthias Runge
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 07:05 EST by Matthias Runge
Modified: 2016-04-07 17:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-8.0.0-10.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, no timeout was specified in horizon's systemd snippet for httpd, so the standard one-minute timeout was used when waiting for httpd to fully start up. In some cases, however, especially when running in a virtualized or a very loaded environment, the startup takes longer. Consequently, a failure from systemd sometimes occurred even if httpd was already running. With this update, the timeout has been set to two minutes, which resolves the problem.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:22:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2016-01-12 07:05:33 EST
Description of problem:
under some circumstances, the standard timeout (60 sec) is not enough for startup. This can happen, when starting everything fully virtualized on a slow or loaded machine.

We should increase the timeout (before it is marked as failed) to 2 mins.


[Service]
ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py collectstatic --noinput --clear
ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py compress --force
TimeoutStartSec=2min

[Unit]
After=memcached.service



Version-Release number of selected component (if applicable):
openstack-dashboard-8.0.0-8.el7ost.noarch
Comment 4 Amit Ugol 2016-01-25 10:47:40 EST
# grep TimeoutStartSec /usr/lib/systemd/system/httpd.service.d/openstack-dashboard.conf 
TimeoutStartSec=2min
Comment 5 errata-xmlrpc 2016-04-07 17:22:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.