Bug 1297788 - repo-rss has missing 'Requires: libxml2-python'
repo-rss has missing 'Requires: libxml2-python'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: yum-utils (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Valentina Mukhamedzhanova
Eva Mrakova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 08:18 EST by Eva Mrakova
Modified: 2016-11-03 20:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: yum-utils-1.1.31-35.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1155093
Environment:
Last Closed: 2016-11-03 20:14:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eva Mrakova 2016-01-12 08:18:19 EST
Also happens for
yum-utils-1.1.31-34.el7.noarch

easy reproducer (when yum-utils is already installed):
1. # rpm -e --nodeps libxml2-python
2. # yum -y reinstall yum-utils
3. # repo-rss -h
Traceback (most recent call last):
  File "/usr/bin/repo-rss", line 25, in <module>
    import libxml2
ImportError: No module named libxml2


+++ This bug was initially created as a clone of Bug #1155093 +++

Description of problem:
yum-utils needs to have a Requires: libxml2-python added as repo-rss requires libxml2-python.

Version-Release number of selected component (if applicable):
yum-utils-1.1.30-30.el6

How reproducible:
Always

Steps to Reproduce:
1.  Do a minimal RHEL-6.6 install then install yum-utils
Comment 5 errata-xmlrpc 2016-11-03 20:14:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2187.html

Note You need to log in before you can comment on or make changes to this bug.