Bug 1297791 - katello-disconnected and pulp-admin disagree as to task status
katello-disconnected and pulp-admin disagree as to task status
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Inter Satellite Sync (Show other bugs)
6.1.5
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On: 1295003
Blocks: rhci-common-installer
  Show dependency treegraph
 
Reported: 2016-01-12 08:19 EST by John Matthews
Modified: 2016-02-08 13:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1295003
Environment:
Last Closed: 2016-02-08 13:23:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2016-01-12 08:19:44 EST
+++ This bug was initially created as a clone of Bug #1295003 +++

Description of problem:

katello-disconnected reports a status but pulp-admin reports a different status.


Version-Release number of selected component (if applicable):

TP2

How reproducible:

100% for specific repo/state

Steps to Reproduce:
1. Setup for disconnected mode
2. Synchronize one repository at a time
3.

Actual results:

katello-disconnected task in error
pulp-admin task is running

Expected results:

both tools report the same status

Additional info:

"katello-disconnected watch --repo-id rhel-6-server-rpms-6Server-x86_64" returns:
State: error:
  repo: [rhel-6-server-rpms-6Server-x86_64] packages remaining: [unknown]
but
pulp-admin repo tasks list --repo-id rhel-6-server-rpms-6Server-x86_64" returns:
perations:  sync
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Failed
Start Time:  2015-12-30T16:09:54Z
Finish Time: 2015-12-30T16:09:55Z
Task Id:     bcf568b1-a5b0-4e34-834c-f4a701c49cbd

Operations:  sync
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Failed
Start Time:  2015-12-30T16:27:44Z
Finish Time: 2015-12-30T16:27:45Z
Task Id:     607a7df7-263e-475a-8fc4-e6512e884110

Operations:  sync
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Failed
Start Time:  2015-12-30T17:02:33Z
Finish Time: 2015-12-30T17:02:34Z
Task Id:     9c42056e-a6de-4e44-bafd-016f5db8e644

Operations:  sync
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Failed
Start Time:  2015-12-30T17:06:17Z
Finish Time: 2015-12-30T17:06:18Z
Task Id:     3691bffc-6053-4c32-a655-1febbef4b1ee

Operations:  sync
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Failed
Start Time:  2015-12-30T20:05:35Z
Finish Time: 2015-12-30T20:05:36Z
Task Id:     b6f63c77-2f47-44b0-85aa-ce91e8b7cdca

Operations:  publish
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Cancelled
Start Time:  2015-12-31T16:57:22Z
Finish Time: 2015-12-31T17:16:32Z
Task Id:     2d7b6b7b-50c0-4ccf-818e-8a86ce0f7c86

Operations:  publish
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Cancelled
Start Time:  Unstarted
Finish Time: Incomplete
Task Id:     97d4c351-0f35-43b9-baef-9898086c532c

Operations:  publish
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Cancelled
Start Time:  Unstarted
Finish Time: Incomplete
Task Id:     4f933cd6-4e30-4ab9-872c-a5e7ef3fada2

Operations:  publish
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Cancelled
Start Time:  Unstarted
Finish Time: Incomplete
Task Id:     46ff9b3d-6acb-48c7-8d23-8765de14d23c

Operations:  delete
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Successful
Start Time:  2015-12-31T17:31:40Z
Finish Time: 2015-12-31T17:32:07Z
Task Id:     71231539-896e-4c94-9417-44e5c1e33442

Operations:  sync
Resources:   rhel-6-server-rpms-6Server-x86_64 (repository)
State:       Running
Start Time:  2015-12-31T17:58:44Z
Finish Time: Incomplete
Task Id:     95bfa35b-ae57-4fd5-b4fe-f0ec9694ee16

pulp-admin status appears to be correct
Comment 1 Bryan Kearney 2016-02-08 13:23:11 EST
The katello-disconnected server synchronization and export functions are being moved into the Satellite server itself. With 6.2, the katello-disconnected command will no longer be delivered and instead will be replaced with a new export and import functions delivered via the UI and hammer CLI. This bug is being closed as "WONTFIX" since it relates only to the existing katello-disconnected tooling. Please check the Satellite docs with the release of Satellite 6.2 on how to use the new content export and import features.

Note You need to log in before you can comment on or make changes to this bug.