Bug 1297796 - openstack-ironic-api is down after undercloud installation
openstack-ironic-api is down after undercloud installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity low
: ---
: 10.0 (Newton)
Assigned To: Hugh Brock
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 08:38 EST by Itzik Brown
Modified: 2016-10-14 15:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 15:53:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ironic api log (37.72 KB, text/plain)
2016-01-12 08:38 EST, Itzik Brown
no flags Details

  None (edit)
Description Itzik Brown 2016-01-12 08:38:56 EST
Created attachment 1113951 [details]
Ironic api log

Description of problem:
After undercloud installation openstack-ironic-api is in failed state
After running systemctl start openstack-ironic-api the service is up and running.

Version-Release number of selected component (if applicable):
RHOS8
RHEL7.2
openstack-ironic-inspector-2.2.2-1.el7ost.noarch
openstack-ironic-conductor-4.2.2-3.el7ost.noarch
openstack-ironic-common-4.2.2-3.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch
python-ironic-inspector-client-1.2.0-5.el7ost.noarch
openstack-ironic-api-4.2.2-3.el7ost.noarch
python-tripleoclient-0.0.11-5.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Install the undercloud
2. Verify the ironic api is down:
# systemctl status openstack-ironic-api


Actual results:


Expected results:


Additional info:
Comment 3 Gonéri Le Bouder 2016-03-07 10:28:45 EST
I've the same problem with the last puddle.

openstack-ironic-inspector-2.2.4-2.el7ost.noarch
python-ironic-inspector-client-1.2.0-6.el7ost.noarch
openstack-ironic-api-4.2.2-4.el7ost.noarch
openstack-ironic-conductor-4.2.2-4.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch
openstack-ironic-common-4.2.2-4.el7ost.noarch
Comment 4 Mike Burns 2016-04-07 17:03:37 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Note You need to log in before you can comment on or make changes to this bug.