Bug 1297826 - [abrt] NetworkManager: complete_script(): nm-dispatcher killed by SIGSEGV
[abrt] NetworkManager: complete_script(): nm-dispatcher killed by SIGSEGV
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rashid Khan
Desktop QE
abrt_hash:dad71efd404557ec2172b719e24...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 09:46 EST by Lubomir Rintel
Modified: 2016-01-12 10:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-12 10:29:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.11 KB, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: cgroup (221 bytes, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: core_backtrace (6.08 KB, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: dso_list (2.87 KB, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: environ (72 bytes, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: limits (1.29 KB, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: machineid (135 bytes, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: maps (14.67 KB, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: open_fds (504 bytes, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: proc_pid_status (1.02 KB, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: var_log_messages (32.36 KB, text/plain)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details
File: sosreport.tar.xz (9.46 MB, application/octet-stream)
2016-01-12 09:47 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2016-01-12 09:46:59 EST
Description of problem:


Version-Release number of selected component:
NetworkManager-1.1.0-13878.4059b253b7.el7_2

Additional info:
reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        /usr/libexec/nm-dispatcher
crash_function: complete_script
executable:     /usr/libexec/nm-dispatcher
global_pid:     26257
kernel:         3.10.0-327.el7.x86_64
runlevel:       N 3
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (2 frames)
 #0 complete_script at nm-dispatcher.c:349
 #1 g_child_watch_dispatch at gmain.c:5148
Comment 1 Lubomir Rintel 2016-01-12 09:47:05 EST
Created attachment 1113972 [details]
File: backtrace
Comment 2 Lubomir Rintel 2016-01-12 09:47:06 EST
Created attachment 1113973 [details]
File: cgroup
Comment 3 Lubomir Rintel 2016-01-12 09:47:07 EST
Created attachment 1113974 [details]
File: core_backtrace
Comment 4 Lubomir Rintel 2016-01-12 09:47:08 EST
Created attachment 1113975 [details]
File: dso_list
Comment 5 Lubomir Rintel 2016-01-12 09:47:09 EST
Created attachment 1113976 [details]
File: environ
Comment 6 Lubomir Rintel 2016-01-12 09:47:10 EST
Created attachment 1113977 [details]
File: limits
Comment 7 Lubomir Rintel 2016-01-12 09:47:11 EST
Created attachment 1113978 [details]
File: machineid
Comment 8 Lubomir Rintel 2016-01-12 09:47:13 EST
Created attachment 1113979 [details]
File: maps
Comment 9 Lubomir Rintel 2016-01-12 09:47:14 EST
Created attachment 1113980 [details]
File: open_fds
Comment 10 Lubomir Rintel 2016-01-12 09:47:15 EST
Created attachment 1113981 [details]
File: proc_pid_status
Comment 11 Lubomir Rintel 2016-01-12 09:47:17 EST
Created attachment 1113982 [details]
File: var_log_messages
Comment 12 Lubomir Rintel 2016-01-12 09:47:36 EST
Created attachment 1113983 [details]
File: sosreport.tar.xz
Comment 14 Thomas Haller 2016-01-12 10:29:21 EST
Fixed upstream:

http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=ddc6d97f00e81cd422bb4d48adcadff70018de0f
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=2b54bd6a53b165f12b8eefe5232ea20cc9d3440c


The no-wait patches were not backported to nm-1-0, and thus rhel-7.2 is not affected.


I'll close this BZ because no rhel-package had this issue and rhel-7.3 will get a version based on nm-1-2 (which is fixed hereby).

Note You need to log in before you can comment on or make changes to this bug.