This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297835 - Host install fails on Fedora 23 due to lack of dep on python2-dnf
Host install fails on Fedora 23 due to lack of dep on python2-dnf
Status: CLOSED CURRENTRELEASE
Product: ovirt-host-deploy
Classification: oVirt
Component: General (Show other bugs)
master
Unspecified Unspecified
low Severity high (vote)
: ovirt-4.0.0-rc3
: 1.5.0
Assigned To: Sandro Bonazzola
Petr Kubica
: Documentation
: 1349453 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 10:05 EST by Tal Nisan
Modified: 2016-07-26 06:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Fedora ONLY Cause: dnf package manager with python 3 is used by default on Fedora >= 23 ovirt-host-deploy is executed by ovirt-engine using python2 Consequence: Host install fails on Fedora 23 due to lack of python2-dnf and yum in the default environment Workaround (if any): install manually python2-dnf on the host before trying to add it to the engine Result: host could now be added
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-26 06:42:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: ovirt‑4.0.0?
rule-engine: planning_ack?
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
Host deploy log (71.08 KB, text/plain)
2016-01-12 10:05 EST, Tal Nisan
no flags Details

  None (edit)
Description Tal Nisan 2016-01-12 10:05:48 EST
Created attachment 1113986 [details]
Host deploy log

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Tal Nisan 2016-01-12 10:07:50 EST
Host deploy fails on new Fedora 23 server host.
Used the ovirt master repo
Comment 2 Yedidyah Bar David 2016-01-12 10:20:22 EST
Can you please try installing on the host 'python2-dnf' and then host-deploy again?
Comment 3 Tal Nisan 2016-01-12 10:55:45 EST
I've installed 'python2-dnf' as you suggested and that indeed solved the problem
Comment 4 Sandro Bonazzola 2016-03-11 09:07:57 EST
Keeping in assigned, I'll move to ON_QA when creating 4.0 release notes.
Comment 5 Sandro Bonazzola 2016-07-06 11:28:59 EDT
Release notes updated: https://github.com/oVirt/ovirt-site/pull/349
Comment 6 Sandro Bonazzola 2016-07-07 07:07:07 EDT
*** Bug 1349453 has been marked as a duplicate of this bug. ***
Comment 7 Lukas Svaty 2016-07-26 06:42:32 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.