Bug 1297859 - Rabbitmq users other that default are lost when disable/enable rabbitmq-cluster pacemaker resource
Rabbitmq users other that default are lost when disable/enable rabbitmq-clust...
Status: CLOSED DUPLICATE of bug 1303803
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Peter Lemenkov
yeylon@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 11:23 EST by Alfredo Moralejo
Modified: 2016-04-18 03:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-11 05:03:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alfredo Moralejo 2016-01-12 11:23:41 EST
Description of problem:

When creating different users in rabbitmq as shown in https://access.redhat.com/articles/1167113 kbase in standard HA configuration, users are lost after disable/enable users.

Version-Release number of selected component (if applicable):

RHEL OSP7 

How reproducible:

Allways

Steps to Reproduce:
1. Create a rabbitmq cluster using rabbitmq-cluster pacemaker resource 
2. Create different users, different that default guest:

# rabbitmqctl add_user cinder CINDER_PASS
# rabbitmqctl add_user nova NOVA_PASS
# rabbitmqctl add_user neutron NEUTRON_PASS
# rabbitmqctl add_user heat HEAT_PASS
# rabbitmqctl add_user glance GLANCE_PASS
# rabbitmqctl add_user ceilometer CEILOMETER_PASS

3. Disable and enable resouce

pcs resource disable rabbitmq-cluster
pcs resource enable rabbitmq-cluster



Actual results:

Users just created are lost.

Expected results:

Users should be kept on pacemaker resources stop/start

Additional info:

rabbitmq-cluster has a wipe function to cleanup all the data dir when bootstraping a cluster. It seems that users are only persisted there and can not be created in rabbitmq.config.
Comment 2 Peter Lemenkov 2016-04-11 05:03:50 EDT

*** This bug has been marked as a duplicate of bug 1303803 ***

Note You need to log in before you can comment on or make changes to this bug.