Bug 1297872 - mutt should use gpg2
mutt should use gpg2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matej Mužila
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 11:46 EST by Till Maas
Modified: 2016-09-08 10:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-08 10:51:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2016-01-12 11:46:26 EST
Description of problem:
with gpg 2.1 gpg 1 and gpg 2 do not share the same secret keys anymore. Mutt only uses gpg 1. Therefore keys that are available only in gpg2 cannot be used.

Version-Release number of selected component (if applicable):
1.5.24

How reproducible:
always

Steps to Reproduce:
1. create gpg key with gpg2 --gen-key
2. try to sign a message with the key

Actual results:
key is not found in mutt

Expected results:
key should be found

Additional info:
Comment 1 Till Maas 2016-01-15 13:02:10 EST
Replacing the gpg.rc contents from /etc/Muttrc with "set crypt_use_gpgme=yes" fixes this. Why is gpgme not used in Fedora's mutt by default?
Comment 2 Michael J Gruber 2016-05-10 03:38:17 EDT
(In reply to Till Maas from comment #1)
> Replacing the gpg.rc contents from /etc/Muttrc with "set
> crypt_use_gpgme=yes" fixes this. Why is gpgme not used in Fedora's mutt by
> default?

gpg is still gpg 1 by default in Fedora, so there is every reason for mutt to use that default gpg by default, unless it requires specific gpg 2(.1) functionality.

The mess with different secret key stores is entirely due to the (one-)way from gpg 1 to gpg 2.1. That surely is confusing, but it's the user's decision to use gpg2.

Luckily, mutt can use gpg 2.1 with a simple config setting, as you confirmed. In particular, it is ready to use that by default once gpg 2.1 is the default gpg in Fedora.

Note You need to log in before you can comment on or make changes to this bug.