Bug 1297911 - List of RHOS events not captured in the control policy.log but captured in evm.log
List of RHOS events not captured in the control policy.log but captured in ev...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Control (Show other bugs)
5.3.0
Unspecified Unspecified
low Severity medium
: GA
: 5.5.3
Assigned To: Lucy Fu
Dmitry Misharov
: ZStream
Depends On: 1180695
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 13:40 EST by Lucy Fu
Modified: 2016-04-13 14:41 EDT (History)
14 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1180695
Environment:
Last Closed: 2016-04-13 14:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-02-10 14:54:42 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=cecc8aaf509234805fe8ea03a44f2e04f417669b

commit cecc8aaf509234805fe8ea03a44f2e04f417669b
Merge: 0131c00 c1a8aa7
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Wed Feb 10 14:25:22 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Wed Feb 10 14:25:22 2016 -0500

    Merge branch '5.5.z-add_os_policy_events_1180695' into '5.5.z'
    
    Connect Openstack events with our Policy events.
    
    A clean cherry-pick of [#5983](https://github.com/ManageIQ/manageiq/pull/5983) and [#6064](https://github.com/ManageIQ/manageiq/pull/6064).
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297911
    
    See merge request !710

 .../OPENSTACK.class/compute_instance_pause_end.yaml        |  2 ++
 .../OPENSTACK.class/compute_instance_reboot_end.yaml       | 14 ++++++++++++++
 .../OPENSTACK.class/compute_instance_reset_end.yaml        | 14 ++++++++++++++
 .../EmsEvent/OPENSTACK.class/compute_instance_resume.yaml  | 12 ------------
 .../OPENSTACK.class/compute_instance_resume_end.yaml       | 14 ++++++++++++++
 .../OPENSTACK.class/compute_instance_snapshot_end.yaml     |  2 +-
 .../OPENSTACK.class/compute_instance_snapshot_start.yaml   | 14 ++++++++++++++
 .../EmsEvent/OPENSTACK.class/compute_instance_suspend.yaml | 12 ------------
 .../OPENSTACK.class/compute_instance_suspend_end.yaml      | 14 ++++++++++++++
 .../OPENSTACK.class/compute_instance_unpause_end.yaml      |  2 ++
 db/fixtures/miq_event_definitions.csv                      |  2 +-
 11 files changed, 76 insertions(+), 26 deletions(-)
Comment 4 Dmitry Misharov 2016-03-30 07:06:36 EDT
Tested on 5.6.0.0-pre-nightly.20160321091612_a8eb2ed. I was able to catch 
following events in policy.log: pause, resume, and create snapshot. 
[----] I, [2016-03-30T04:37:29.965368 #9851:873994]  INFO -- : MIQ(action-invoke) Invoking action [Generate log message] for successful policy [Bug verifying], event: [VM Snapshot Create Complete], entity name: [test_inst_pwrctl_FoHFCrWK], entity type: [ManageIQ::Providers::Openstack::CloudManager::Vm], sequence: [1], synchronous? [false]
[----] I, [2016-03-30T04:45:43.924893 #9851:873994]  INFO -- : MIQ(action-invoke) Invoking action [Generate log message] for successful policy [Bug verifying], event: [VM Pause], entity name: [test_inst_pwrctl_FoHFCrWK], entity type: [ManageIQ::Providers::Openstack::CloudManager::Vm], sequence: [1], synchronous? [false]
[----] I, [2016-03-30T04:49:31.810068 #25508:873994]  INFO -- : MIQ(action-invoke) Invoking action [Generate log message] for successful policy [Bug verifying], event: [VM Resume], entity name: [test_inst_pwrctl_FoHFCrWK], entity type: [ManageIQ::Providers::Openstack::CloudManager::Vm], sequence: [1], synchronous? [false]
These following events: soft reboot, hard reboot, suspend, editing instance, edit security group - were not captured in policy.log.
Lucy please tell, whether the other events were fixed as part of this bug or not?
Comment 11 CFME Bot 2016-04-01 16:43:06 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a034e171258f08ba7acf044d08b5ef64db5a212e

commit a034e171258f08ba7acf044d08b5ef64db5a212e
Merge: d74e68f 6b3c299
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Fri Apr 1 16:08:17 2016 -0400
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Fri Apr 1 16:08:17 2016 -0400

    Merge branch '5.5.z-openstack_event_suspend_reboot_1180695' into '5.5.z'
    
    Enable policy events for Openstack suspend and reboot.
    
    Clean cherry-pick of [#7659](https://github.com/ManageIQ/manageiq/pull/7659).
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1297911
    
    See merge request !883

 .../OPENSTACK.class/compute_instance_reboot_end.yaml       |  2 +-
 .../OPENSTACK.class/compute_instance_reset_end.yaml        |  2 +-
 .../EmsEvent/OPENSTACK.class/compute_instance_suspend.yaml | 14 ++++++++++++++
 .../OPENSTACK.class/compute_instance_suspend_end.yaml      | 14 --------------
 4 files changed, 16 insertions(+), 16 deletions(-)
Comment 13 Dmitry Misharov 2016-04-06 08:51:13 EDT
Tested and verified on 5.5.3.3.20160405132708_92d2d67.
Comment 15 errata-xmlrpc 2016-04-13 14:41:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.