Bug 1297920 - VM can't be created in Cluster level 3.5
VM can't be created in Cluster level 3.5
Status: CLOSED DUPLICATE of bug 1143869
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.3
: ---
Assigned To: Martin Sivák
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-12 13:48 EST by jniederm
Modified: 2016-01-27 09:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 09:09:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dfediuck: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
error_dialog (12.43 KB, image/png)
2016-01-12 13:48 EST, jniederm
no flags Details
engine log (974 bytes, text/plain)
2016-01-12 13:49 EST, jniederm
no flags Details

  None (edit)
Description jniederm 2016-01-12 13:48:11 EST
Created attachment 1114089 [details]
error_dialog

Description of problem:
VM can't be created in Cluster level 3.5. Following error message show:

    User doesn't have permissions to assign the cpu profile Cluster35
    with id cd822c5a-e251-40c4-87a8-2f9ac7d015ae to VMs.

Version-Release number of selected component (if applicable):
4.0 master, commit 711b12c

How reproducible:
100%

Steps to Reproduce:
1. Set DC compatibility level to 3.5
2. Set Cluster compatibility level to 3.5
3. Try to create new VM in cluster above.

Actual results:
Error dialog shown

Expected results:
Vm created

Additional info:
Comment 1 jniederm 2016-01-12 13:49 EST
Created attachment 1114093 [details]
engine log
Comment 2 Doron Fediuck 2016-01-13 02:14:50 EST
The issue here is about sufficient permissions as you can see in the
error message.

Did you make sure the user has permissions for the relevant CPU profile?
I suggest you review [1] and let us know where you see an issue.


[1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html-single/Administration_Guide/index.html#sect-CPU_Quality_of_Service
Comment 3 jniederm 2016-01-13 09:24:17 EST
It occurs when user is signed into webadmin as admin@internal. 'admin' user should not be restricted by any permissions, right?
Comment 4 Doron Fediuck 2016-01-19 08:58:42 EST
(In reply to jniederm from comment #3)
> It occurs when user is signed into webadmin as admin@internal. 'admin' user
> should not be restricted by any permissions, right?

This is correct.
Can you please provide the engine RPM version you have installed.
Comment 5 jniederm 2016-01-19 09:12:01 EST
I discovered that bug in my dev build from 4.0 master, commit 711b12c (comment 0, version). So no RPMs.
Comment 6 Tomer Saban 2016-01-27 09:09:02 EST
This bug has a patch that will be uploaded for Bug 1143869. Therefore, I'm marking it as a duplicate of 1143869 since it's the closest explanation for this issue. 

The patch that will fix this bug is:
https://gerrit.ovirt.org/#/c/52727/

*** This bug has been marked as a duplicate of bug 1143869 ***

Note You need to log in before you can comment on or make changes to this bug.