Bug 1297974 - Self Service : User with role "EvmGroup-support " is able to see requests raised by admin
Self Service : User with role "EvmGroup-support " is able to see requests rai...
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.7.0
Assigned To: Tim Wade
Shveta
ssui
: TestOnly, ZStream
: 1340311 (view as bug list)
Depends On:
Blocks: 1298705 1343516 1383482
  Show dependency treegraph
 
Reported: 2016-01-12 16:48 EST by Shveta
Modified: 2017-01-12 00:10 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.7.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298705 1383482 (view as bug list)
Environment:
Last Closed: 2017-01-11 15:09:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all requests (109.31 KB, image/png)
2016-01-12 16:48 EST, Shveta
no flags Details

  None (edit)
Description Shveta 2016-01-12 16:48:06 EST
Created attachment 1114155 [details]
all requests

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create few requests as admin
2. Create a role with  EvmGroup-support  Group
3. Login as that user into self service UI . User can see all requests .


Actual results:


Expected results:


Additional info:
5.5.0.13.20151201120956_653c0d4
Comment 3 Tim Wade 2016-03-03 12:50:20 EST
This will be solved at least in part by https://github.com/ManageIQ/manageiq/pull/6651
Comment 4 Tim Wade 2016-05-09 14:44:00 EDT
Part 2 is solved here: https://github.com/ManageIQ/manageiq/pull/8554
Comment 5 Tim Wade 2016-07-25 11:44:39 EDT
*** Bug 1340311 has been marked as a duplicate of this bug. ***
Comment 7 Shveta 2016-10-11 16:27:22 EDT
Fixed.
verified in 5.7.0.4-alpha1.20161005153002_cfc8a23

Note You need to log in before you can comment on or make changes to this bug.