This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1297975 - Neutron VLAN ranges ignored except for first bridge on 7.2
Neutron VLAN ranges ignored except for first bridge on 7.2
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity high
: y3
: 7.0 (Kilo)
Assigned To: Brad P. Crochet
Itzik Brown
: TestOnly
Depends On:
Blocks: 1243520 1299086
  Show dependency treegraph
 
Reported: 2016-01-12 16:51 EST by Dan Sneddon
Modified: 2017-10-09 17:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1299086 (view as bug list)
Environment:
Last Closed: 2016-02-18 11:49:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Sneddon 2016-01-12 16:51:54 EST
Description of problem:
When deploying multiple VLAN bridges, and including the --neutron-vlan-ranges on the command-line, only the first set of VLAN ranges is included in /etc/neutron/plugin.ini

Version-Release number of selected component (if applicable):
OSP-Director 7.2

How reproducible:
100% (I believe)

Steps to Reproduce:
1. Deploy with multiple bridges using --neutron-bridge-mappings datacentre:br-ex,physnet-tenant:br-tenant,floating:br-floating
2. Also use --neutron-vlan-ranges br-tenant:270:420,tenant:160:160
3.

Actual results:
/etc/neutron/plugin.ini has the following:
network_vlan_ranges =br-tenant:270:420

Expected results:
/etc/neutron/plugin.ini should have the following:
network_vlan_ranges =br-tenant:270:420,floating:160:160

Additional info:
This appears to be a regression, in 7.1 the VLAN ranges were put into /etc/neutron/plugin.ini correctly.
Comment 3 Brad P. Crochet 2016-01-20 08:54:44 EST
I was unable to reproduce this on the latest 7.x puddle.
Comment 4 Mike Burns 2016-01-20 12:43:06 EST
Can you please retest with the latest code?
Comment 5 Toni Freger 2016-01-24 06:03:48 EST
Please add "fixed in version" information in order us to start testing this issue.
Comment 6 Itzik Brown 2016-01-25 06:38:46 EST
Ran:
# openstack overcloud deploy --templates     --control-scale 3 --compute-scale 1 --ntp-server clock.redhat.com  --libvirt-type qemu --neutron-network-vlan-ranges tenant:270:420,floating:160:160 --neutron-bridge-mappings datacentre:br-ex,tenant:br-tenant,floating:br-floating

On the controller I see:

/etc/neutron/plugin.ini
========================
network_vlan_ranges =tenant:270:420,floating:160:160

/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
=======================================================
bridge_mappings =datacentre:br-ex,tenant:br-tenant,floating:br-floating

Version
=============
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch
openstack-tripleo-common-0.0.1.dev6-5.git49b57eb.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-111.el7ost.noarch
openstack-tripleo-image-elements-0.9.6-10.el7ost.noarch
openstack-tripleo-0.0.7-0.1.1664e566.el7ost.noarch
openstack-puppet-modules-2015.1.8-43.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.1-5.el7ost.noarch
python-neutron-2015.1.2-7.el7ost.noarch
openstack-neutron-2015.1.2-7.el7ost.noarch
Comment 8 errata-xmlrpc 2016-02-18 11:49:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html

Note You need to log in before you can comment on or make changes to this bug.