Bug 1297985 - pacemaker: console mode no longer available for crm_mon
pacemaker: console mode no longer available for crm_mon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pacemaker (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Pokorný
Fedora Extras Quality Assurance
:
Depends On:
Blocks: harden-failure
  Show dependency treegraph
 
Reported: 2016-01-12 18:53 EST by Benjamin Ash
Modified: 2016-01-29 13:36 EST (History)
4 users (show)

See Also:
Fixed In Version: pacemaker-1.1.14-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 13:28:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Ash 2016-01-12 18:53:29 EST
Description of problem: Pacemaker's crm_mon cannot run in 'console' mode and emits the following when run without any command line options:

"""
Defaulting to one-shot mode
You need to have curses available at compile time to enable console mode
"""

This appears to be regression related to Fedora 23.


Version-Release number of selected component (if applicable):


How reproducible: easily


Steps to Reproduce:
1. install pacemaker-1.1.13-3.fc23.x86_64
2. execute crm_mon
3.

Actual results:
- crm_mon does not go into console mode.


Expected results:
- crm_mon does not go into console mode.

Additional info:
This functionality used to work on Fedora 22. The system was upgraded from Fedora 21 to Fedora 23 using fedup


[root@ts-bldsrvweb3 ~]# crm_mon
Defaulting to one-shot mode
You need to have curses available at compile time to enable console mode

ldd output:
ldd /usr/sbin/crm_mon
	linux-vdso.so.1 (0x00007fff3a0e2000)
	libpe_status.so.4 => /lib64/libpe_status.so.4 (0x00007f0db2bda000)
	libstonithd.so.2 => /lib64/libstonithd.so.2 (0x00007f0db29c9000)
	libpengine.so.4 => /lib64/libpengine.so.4 (0x00007f0db2773000)
	libcib.so.4 => /lib64/libcib.so.4 (0x00007f0db2553000)
	libcrmcommon.so.3 => /lib64/libcrmcommon.so.3 (0x00007f0db22f9000)
	libpe_rules.so.2 => /lib64/libpe_rules.so.2 (0x00007f0db20ed000)
	libncurses.so.5 => /lib64/libncurses.so.5 (0x00007f0db1ec7000)
	libtinfo.so.5 => /lib64/libtinfo.so.5 (0x00007f0db1c9d000)
	libcpg.so.4 => /lib64/libcpg.so.4 (0x00007f0db1a96000)
	libcfg.so.6 => /lib64/libcfg.so.6 (0x00007f0db1892000)
	libcmap.so.4 => /lib64/libcmap.so.4 (0x00007f0db168c000)
	libquorum.so.5 => /lib64/libquorum.so.5 (0x00007f0db1488000)
	libgnutls.so.30 => /lib64/libgnutls.so.30 (0x00007f0db1155000)
	libcorosync_common.so.4 => /lib64/libcorosync_common.so.4 (0x00007f0db0f52000)
	libbz2.so.1 => /lib64/libbz2.so.1 (0x00007f0db0d41000)
	libxslt.so.1 => /lib64/libxslt.so.1 (0x00007f0db0b02000)
	libxml2.so.2 => /lib64/libxml2.so.2 (0x00007f0db0799000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f0db03d7000)
	libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f0db01d2000)
	libpam.so.0 => /lib64/libpam.so.0 (0x00007f0daffc3000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007f0dafc89000)
	libltdl.so.7 => /lib64/libltdl.so.7 (0x00007f0dafa7f000)
	libqb.so.0 => /lib64/libqb.so.0 (0x00007f0daf819000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f0daf614000)
	librt.so.1 => /lib64/librt.so.1 (0x00007f0daf40c000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0daf1ef000)
	libz.so.1 => /lib64/libz.so.1 (0x00007f0daefd8000)
	libp11-kit.so.0 => /lib64/libp11-kit.so.0 (0x00007f0daed71000)
	libidn.so.11 => /lib64/libidn.so.11 (0x00007f0daeb3d000)
	libtasn1.so.6 => /lib64/libtasn1.so.6 (0x00007f0dae92a000)
	libnettle.so.6 => /lib64/libnettle.so.6 (0x00007f0dae6f2000)
	libhogweed.so.4 => /lib64/libhogweed.so.4 (0x00007f0dae4c6000)
	libgmp.so.10 => /lib64/libgmp.so.10 (0x00007f0dae24e000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f0dadf4b000)
	liblzma.so.5 => /lib64/liblzma.so.5 (0x00007f0dadd25000)
	/lib64/ld-linux-x86-64.so.2 (0x0000563d8c42e000)
	libaudit.so.1 => /lib64/libaudit.so.1 (0x00007f0dadafe000)
	libffi.so.6 => /lib64/libffi.so.6 (0x00007f0dad8f5000)
Comment 1 Jan Pokorný 2016-01-15 13:15:40 EST
Thanks for the report.

Was already notified about this regression and now when we have new
upstream release (also to be delivered to Fedora), let's finally have
this tackled.

I identified the issue is with this test in autoconf script:
https://github.com/ClusterLabs/pacemaker/blob/Pacemaker-1.1.14/configure.ac#L950

My current guess is that the test is not passing well due to some
new warning being emitted when compiling the test code and this warning
is then turned to error due to -Werror, which makes the overall test fail,
leaving ncurses out of play.

Have to try this directly in F23 environment.
Comment 2 Jan Pokorný 2016-01-18 11:22:57 EST
This is why in, still needing a bit of investigation:
> /usr/bin/ld: /tmp/ccEgB41c.o: relocation R_X86_64_32 against `.rodata'
>   can not be used when making a shared object; recompile with -fPIC
> /tmp/ccEgB41c.o: error adding symbols: Bad value
Comment 3 Jan Pokorný 2016-01-18 14:19:56 EST
This patch seems to fix the issue:

https://pkgs.fedoraproject.org/cgit/rpms/pacemaker.git/tree/bz1297985-fix-configure-curses-test.patch

It's included in new Rawhide build of Pacemaker-1.1.14:
https://koji.fedoraproject.org/koji/buildinfo?buildID=712130

F23 version is underway, release will be referenced automatically.
Comment 4 Fedora Update System 2016-01-18 15:48:23 EST
pacemaker-1.1.14-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ecd87327d8
Comment 5 Fedora Update System 2016-01-19 22:54:23 EST
pacemaker-1.1.14-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ecd87327d8
Comment 6 Fedora Update System 2016-01-28 13:28:53 EST
pacemaker-1.1.14-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Benjamin Ash 2016-01-28 13:31:00 EST
Looks great. Thanks.
Comment 8 Jan Pokorný 2016-01-29 13:36:19 EST
Nice to hear back!

For posterity, upstream PR:
https://github.com/ClusterLabs/pacemaker/pull/894
(commits 08a617c + 0333174)

Note You need to log in before you can comment on or make changes to this bug.