Bug 1298027 - qemu-img compare is unnessarily slow on raw files
Summary: qemu-img compare is unnessarily slow on raw files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Fam Zheng
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-13 02:59 UTC by Fam Zheng
Modified: 2016-11-07 20:54 UTC (History)
9 users (show)

Fixed In Version: QEMU 2.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:54:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Fam Zheng 2016-01-13 02:59:35 UTC
"qemu-img compare" is unnecessarily slow on empty raw files:

----- 8< -----

$ for fmt in raw qcow2; do \
    for f in a b; do \
        qemu-img create -f $fmt $f 1G \
    done \
    time qemu-img compare a b \
  done

Formatting 'a', fmt=raw size=1073741824
Formatting 'b', fmt=raw size=1073741824
Images are identical.

real    0m6.424s
user    0m0.177s
sys     0m6.194s
Formatting 'a', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16
Formatting 'b', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16
Images are identical.

real    0m0.008s
user    0m0.005s
sys     0m0.003s

----- 8< -----

Ideally, because the new created raw files are empty:

$ qemu-img info a
image: a
file format: raw
virtual size: 5.0G (5368709120 bytes)
disk size: 0
Images are identical.

The efficiency of qemu-img compare operation should be close to qcow2 if not more.

Comment 2 Fam Zheng 2016-02-15 02:34:16 UTC
Upstream commit:

commit 25ad8e6e95770d4f01844dc2542d861e73b174b2
Author: Fam Zheng <famz@redhat.com>
Date:   Wed Jan 13 16:37:41 2016 +0800

    qemu-img: Speed up comparing empty/zero images

Comment 3 Mike McCune 2016-03-28 22:35:49 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 5 weliao 2016-05-24 03:24:09 UTC
Reproduce this bug with following version:
qemu-img-rhev-2.3.0-31.el7.x86_64
Steps:
# for a in raw qcow2; do for b in c d; do qemu-img create -f $a $b 5G; done; time qemu-img compare c d; done
Formatting 'c', fmt=raw size=5368709120
Formatting 'd', fmt=raw size=5368709120
Images are identical.

real	0m3.616s
user	0m0.455s
sys	0m3.179s
Formatting 'c', fmt=qcow2 size=5368709120 encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16
Formatting 'd', fmt=qcow2 size=5368709120 encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16
Images are identical.

real	0m0.014s
user	0m0.008s
sys	0m0.006s

So this bug reproduced
---------------------------------------------------------
Verified this bug with following version:
qemu-img-rhev-2.6.0-1.el7.x86_64
Steps:
# for a in raw qcow2; do for b in c d; do qemu-img create -f $a $b 5G; done; time qemu-img compare c d; done
Formatting 'c', fmt=raw size=5368709120
Formatting 'd', fmt=raw size=5368709120
Images are identical.

real	0m0.011s
user	0m0.007s
sys	0m0.004s
Formatting 'c', fmt=qcow2 size=5368709120 encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16
Formatting 'd', fmt=qcow2 size=5368709120 encryption=off cluster_size=65536 lazy_refcounts=off refcount_bits=16
Images are identical.

real	0m0.012s
user	0m0.008s
sys	0m0.004s

according to this result.  The bug is fixed.

Comment 8 errata-xmlrpc 2016-11-07 20:54:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.