Bug 129804 - Evolution unable to connect to POP server after yum update
Evolution unable to connect to POP server after yum update
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 15:45 EDT by Benoit Baudot
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 16:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpdump result (3.75 KB, text/plain)
2004-08-14 11:12 EDT, Benoit Baudot
no flags Details

  None (edit)
Description Benoit Baudot 2004-08-12 15:45:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
Just After a fresh install from Fedora Core 2 CD's, evolution and
other mailers are working fine. But as the uptodate applet warns me
that a huge set of updates are available I updated my system with yum
(yum update). It's where the problems are appearing.

When I start evolution and click on [Send/Receive] button the 'Send &
Receive Mail' dialog pops up and hangs in the waiting state for the
pop server.

When I click on the [Cancel] button of the dialog, a new dialog 'Enter
Password for myUsername@swing.be' prompts me for my password and
displays the message 'Unable to connect to POP server pop.swing.be.
Error sending password: Unknown error'

The last dialog endlessly comes back with the same error message each
time I click on the [OK] button.

The same behaviour appeared when I tried other mailers (mozilla-mailer
-1.7.2-0.2.0 and thunderbird-0.7.3) : they both hang when connecting
to the pop server.

Version-Release number of selected component (if applicable):
evolution-1.4.6-2

How reproducible:
Always

Steps to Reproduce:
1. launch evolution from the Gnome Panel
2. click on the [Send/Receive] button
3. here is the bug; the mailer hangs
    

Expected Results:  sucessful connection to POP server (obviously)

Additional info:
Comment 1 Benoit Baudot 2004-08-14 11:12:48 EDT
Created attachment 102728 [details]
tcpdump result
Comment 2 Benoit Baudot 2004-08-14 11:15:03 EDT
As you can see in the attached log file there is a problem with the
dns related packets (bad udp cksum). The problem occurs while running
the 2.6.7 kernel version.

I solved the problem by opening the firewall for udp port 53 and
retricted the allowed sender ip to my ISP's dns servers. Then I
rebooted with kernel 2.6.5. All works fine.

I can now say that the problem is related to the 2.6.7 version of the
kernel but don't know exactly where the problem is.
Comment 3 Matthew Miller 2005-04-26 12:37:38 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 5 John Thacker 2006-10-25 16:57:07 EDT
Closing per lack of response.  Also note that FC1 and FC2 are no longer
supported even by Fedora Legacy.  If this still occurs on FC3 or FC4, please
assign to that version and Fedora Legacy.  If it still occurs on FC5 or FC6,
please reopen and assign to the correct version.

Note You need to log in before you can comment on or make changes to this bug.