Bug 129806 - Doesn't activate s-ata swap partition
Doesn't activate s-ata swap partition
Status: CLOSED DUPLICATE of bug 130288
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-12 16:02 EDT by Ulrich Schulz
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 01:44:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Schulz 2004-08-12 16:02:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040720 Firefox/0.9.1

Description of problem:
After installing the latest kernel (2.6.7-1.494.2.2) the system
doesn't activate my swap partition.
The swap partition is /dev/hde8 (S-ATA device).
A workaround is to /sbin/swapon /dev/sda8.

The problem occured the first time on kernel 2.6.7-1.494.2.2, earlier
kernel still work.

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
1. /sbin/swapon /dev/hde8
2. cat /proc/swaps -> empty, no swap partition activated


Actual Results:  swapon: /dev/hde8: No such device or address

Expected Results:  activated swap partition

Additional info:
Comment 1 Ulrich Schulz 2004-08-21 08:55:31 EDT
Same problem occurs in kernel-2.6.8-1.521
Comment 2 Dave Jones 2005-02-24 01:44:32 EST
your /etc/fstab likely still references your sata drive as /dev/hdX, whereas in
2.6.7+ its now /dev/sdX


*** This bug has been marked as a duplicate of 130288 ***

Note You need to log in before you can comment on or make changes to this bug.