Bug 1298062 - virt-who isn't terminated when run "virt-who --libvirt -o -d"
virt-who isn't terminated when run "virt-who --libvirt -o -d"
Status: CLOSED DUPLICATE of bug 1297623
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.8
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Eko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 01:06 EST by Liushihui
Modified: 2016-11-30 19:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 02:04:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2016-01-13 01:06:37 EST
Description of problem:
When run virt-who command line to monitor remote libvirt at one-shot mode, virt-who can't exist.

Version-Release number of selected component (if applicable):
virt-who-0.16-1.el6.noarch
subscription-manager-1.16.7-1.el6.x86_64
python-rhsm-1.16.5-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Register system to satellite6.1
2. Run virt-who command line to monitor remote libvirt at one-shot mode.
[root@lenovo-rd230-02 ~]#  virt-who --libvirt --libvirt-owner=ACME_Corporation --libvirt-env=Library --libvirt-server=ibm-hs22-04.lab.bos.redhat.com --libvirt-username=root --libvirt-password=-o -d
2016-01-13 00:52:22,805 [virtwho.init INFO] MainProcess(2124):MainThread @virtwho.py:parseOptions:720 - Using reporter_id='lenovo-rd230-02.khw.lab.eng.bos.redhat.com'
2016-01-13 00:52:22,807 [virtwho.init WARNING] MainProcess(2124):MainThread @config.py:checkOptions:255 - Password authentication doesn't work with ssh transport on libvirt backend, copy your public ssh key to the remote machine
2016-01-13 00:52:22,807 [virtwho.init INFO] MainProcess(2124):MainThread @virtwho.py:main:811 - Using configuration "env/cmdline" ("libvirt" mode)
2016-01-13 00:52:22,809 [virtwho.main DEBUG] MainProcess(2124):MainThread @virtwho.py:run:287 - Starting infinite loop with 60 seconds interval
2016-01-13 00:52:22,934 [virtwho.env_cmdline DEBUG] Libvirtd-1(2131):MainThread @virt.py:run:338 - Virt backend 'env/cmdline' started
2016-01-13 00:52:22,936 [virtwho.env_cmdline INFO] Libvirtd-1(2131):MainThread @libvirtd.py:_get_url:124 - Protocol is not specified in libvirt url, using qemu+ssh://
2016-01-13 00:52:22,937 [virtwho.env_cmdline INFO] Libvirtd-1(2131):MainThread @libvirtd.py:_get_url:135 - Libvirt path is not specified in the url, using /system
2016-01-13 00:52:22,937 [virtwho.env_cmdline INFO] Libvirtd-1(2131):MainThread @libvirtd.py:_connect:156 - Using libvirt url: qemu+ssh://root@ibm-hs22-04.lab.bos.redhat.com/system?no_tty=1
2016-01-13 00:52:23,334 [virtwho.env_cmdline DEBUG] Libvirtd-1(2131):MainThread @libvirtd.py:_listDomains:234 - Virtual machine found: 6.7_Server_x86_64: ae5c2627-b039-2bdf-aeb4-022ca47b77f7
2016-01-13 00:52:23,334 [virtwho.env_cmdline DEBUG] Libvirtd-1(2131):MainThread @libvirtd.py:_listDomains:238 - Libvirt domains found: ae5c2627-b039-2bdf-aeb4-022ca47b77f7
2016-01-13 00:52:23,334 [virtwho.env_cmdline DEBUG] Libvirtd-1(2131):MainThread @virt.py:enqueue:331 - Report gathered, putting to queue for sending
2016-01-13 00:52:23,339 [virtwho.main DEBUG] MainProcess(2124):MainThread @virtwho.py:update_report_to_send:274 - Report for config "env/cmdline" updated
2016-01-13 00:52:23,351 [virtwho.main DEBUG] MainProcess(2124):MainThread @subscriptionmanager.py:_connect:112 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2016-01-13 00:52:25,100 [virtwho.main DEBUG] MainProcess(2124):MainThread @subscriptionmanager.py:hypervisorCheckIn:149 - Checking if server has capability 'hypervisor_async'
2016-01-13 00:52:26,821 [virtwho.main DEBUG] MainProcess(2124):MainThread @subscriptionmanager.py:hypervisorCheckIn:161 - Server does not have 'hypervisors_async' capability
2016-01-13 00:52:26,821 [virtwho.main INFO] MainProcess(2124):MainThread @subscriptionmanager.py:hypervisorCheckIn:170 - Sending update in hosts-to-guests mapping: 1 hypervisors and 1 guests found
2016-01-13 00:52:26,821 [virtwho.main DEBUG] MainProcess(2124):MainThread @subscriptionmanager.py:hypervisorCheckIn:171 - Host-to-guest mapping: {
    "16130062-e41c-11de-a372-89b36c16c66c": [
        {
            "guestId": "ae5c2627-b039-2bdf-aeb4-022ca47b77f7", 
            "state": 5, 
            "attributes": {
                "active": 0, 
                "hypervisorVersion": "0.12.1", 
                "virtWhoType": "libvirt", 
                "hypervisorType": "QEMU"
            }
        }
    ]
}
2016-01-13 00:52:28,876 [virtwho.main DEBUG] MainProcess(2124):MainThread @virtwho.py:send_current_report:206 - Report for config "env/cmdline" sent

Actual results:
Virt-who hang there and virt-who isn't terminated 

Expected results:
Virt-who will terminate after send out host/guest mapping to server when run at one-shot mode 

Additional info:
It hasn't this problem when run at the following mode.
Local libvirt: # virt-who -o -d
esx : virt-who --esx -o -d
rhevm: virt-who --rhevm -o -d
Comment 1 Radek Novacek 2016-01-19 02:04:52 EST
Seems to be duplicate of 1297623.

*** This bug has been marked as a duplicate of bug 1297623 ***

Note You need to log in before you can comment on or make changes to this bug.