Bug 1298082 - [abrt] docker-compose: utils.py:57:parallel_execute:ReadTimeout: UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)
[abrt] docker-compose: utils.py:57:parallel_execute:ReadTimeout: UnixHTTPConn...
Status: CLOSED DUPLICATE of bug 1293264
Product: Fedora
Classification: Fedora
Component: docker-compose (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Hampton
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:24aa4ae2a560c0d2ea3503f6295...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 03:34 EST by Yajo
Modified: 2016-01-15 03:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 16:51:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.41 KB, text/plain)
2016-01-13 03:34 EST, Yajo
no flags Details
File: environ (1.02 KB, text/plain)
2016-01-13 03:34 EST, Yajo
no flags Details

  None (edit)
Description Yajo 2016-01-13 03:34:16 EST
Version-Release number of selected component:
docker-compose-1.4.2-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python2 /usr/bin/docker-compose -f production.yml rm
executable:     /usr/bin/docker-compose
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
utils.py:57:parallel_execute:ReadTimeout: UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)

Traceback (most recent call last):
  File "/usr/bin/docker-compose", line 9, in <module>
    load_entry_point('docker-compose==1.4.2', 'console_scripts', 'docker-compose')()
  File "/usr/lib/python2.7/site-packages/compose/cli/main.py", line 39, in main
    command.sys_dispatch()
  File "/usr/lib/python2.7/site-packages/compose/cli/docopt_command.py", line 21, in sys_dispatch
    self.dispatch(sys.argv[1:], None)
  File "/usr/lib/python2.7/site-packages/compose/cli/command.py", line 27, in dispatch
    super(Command, self).dispatch(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/compose/cli/docopt_command.py", line 24, in dispatch
    self.perform_command(*self.parse(argv, global_options))
  File "/usr/lib/python2.7/site-packages/compose/cli/command.py", line 59, in perform_command
    handler(project, command_options)
  File "/usr/lib/python2.7/site-packages/compose/cli/main.py", line 268, in rm
    v=options.get('-v', False)
  File "/usr/lib/python2.7/site-packages/compose/project.py", line 232, in remove_stopped
    msg="Removing"
  File "/usr/lib/python2.7/site-packages/compose/utils.py", line 57, in parallel_execute
    raise errors[msg_index]
ReadTimeout: UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)

Local variables in innermost frame:
q: <Queue.Queue instance at 0x7f395043c878>
errors: {u'odoogrupoesoc_db_1': ReadTimeout(ReadTimeoutError("UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)",),)}
obj: <Container: odoogrupoesoc_appdata_1 (050733)>
stream: <open file '<stdout>', mode 'w' at 0x7f395ecc7150>
lines: [u'odoogrupoesoc_https_1', u'odoogrupoesoc_app_1', u'odoogrupoesoc_db_1', u'odoogrupoesoc_dbdata_1', u'odoogrupoesoc_appdata_1']
an_object: <Container: odoogrupoesoc_appdata_1 (050733)>
objects: [<Container: odoogrupoesoc_https_1 (adb916)>, <Container: odoogrupoesoc_app_1 (15f22e)>, <Container: odoogrupoesoc_db_1 (1cedf4)>, <Container: odoogrupoesoc_dbdata_1 (1ffbdc)>, <Container: odoogrupoesoc_appdata_1 (050733)>]
msg_index: u'odoogrupoesoc_db_1'
done: 4
result: 'unexpected_exception'
total_to_execute: 5
msg: u'Removing'
inner_execute_function: <function inner_execute_function at 0x7f3950704c80>
obj_callable: <function <lambda> at 0x7f395074a6e0>
t: <Thread(Thread-5, stopped daemon 139884102432512)>
Comment 1 Yajo 2016-01-13 03:34:21 EST
Created attachment 1114305 [details]
File: backtrace
Comment 2 Yajo 2016-01-13 03:34:22 EST
Created attachment 1114306 [details]
File: environ
Comment 3 Michael Hampton 2016-01-14 16:51:00 EST
I'm pretty sure this is the same issue you had in bug 1293264.

*** This bug has been marked as a duplicate of bug 1293264 ***
Comment 4 Yajo 2016-01-15 03:16:57 EST
I wish I could provide you with more info, but I can't remember right now. :S

Note You need to log in before you can comment on or make changes to this bug.