Bug 1298091 - Poll VMs get UserVmManager role assigned automatically
Poll VMs get UserVmManager role assigned automatically
Status: CLOSED DUPLICATE of bug 1298094
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.6
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: nobody nobody
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 03:55 EST by Roman Hodain
Modified: 2016-01-13 05:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 05:21:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Hodain 2016-01-13 03:55:08 EST
Description of problem:
    When a user which do not have the system permission "Manipulate Permissions" creates a pool. All the pool VMs get this user as UserVmManager.

Version-Release number of selected component (if applicable):
   RHEV-M 3.5.6

How reproducible:
   100%

Steps to Reproduce:
Create user with the following permissions:
    CREATE_VM
    EDIT_VM_PROPERTIES
    VM_BASIC_OPERATIONS
    CHANGE_VM_CD
    MIGRATE_VM
    CONNECT_TO_VM
    IMPORT_EXPORT_VM
    CONFIGURE_VM_NETWORK
    CONFIGURE_VM_STORAGE
    MOVE_VM
    MANIPULATE_VM_SNAPSHOTS
    RECONNECT_TO_VM
    CHANGE_VM_CUSTOM_PROPERTIES
    CREATE_INSTANCE
    CREATE_TEMPLATE
    EDIT_TEMPLATE_PROPERTIES
    COPY_TEMPLATE
    CONFIGURE_TEMPLATE_NETWORK
    CREATE_VM_POOL
    EDIT_VM_POOL_CONFIGURATION
    DELETE_VM_POOL
    VM_POOL_BASIC_OPERATIONS
    LOGIN
    TAG_MANAGEMENT
    BOOKMARK_MANAGEMENT
    EVENT_NOTIFICATION_MANAGEMENT
    ATTACH_DISK_PROFILE

Create pool with this user.

Actual results:
     All pool VM has the user as UserVmManager assigned

Expected results:
     There are no permissions assigned to the pool VMs
Comment 1 Roman Hodain 2016-01-13 05:21:07 EST

*** This bug has been marked as a duplicate of bug 1298094 ***

Note You need to log in before you can comment on or make changes to this bug.