Bug 1298095 - 1.2.11.15-68.el6_7 ns-slapd crash in ipa context - c_mutex lock memory corruption and self locks
1.2.11.15-68.el6_7 ns-slapd crash in ipa context - c_mutex lock memory corrup...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.7
x86_64 Linux
urgent Severity high
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: ZStream
: 1363883 (view as bug list)
Depends On: 1296694
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 04:00 EST by Jan Kurik
Modified: 2016-08-04 12:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-70.el6_7
Doc Type: Bug Fix
Doc Text:
Prior to this update, fixing a deadlock in the asynchronous simple paged results requests caused another self deadlock due to a regression. To address this problem, a simple PR_Lock on a connection object has been replaced with a re-entrant PR_Monitor. As a result, the self deadlock no longer occurs.
Story Points: ---
Clone Of: 1296694
Environment:
Last Closed: 2016-03-22 10:47:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-01-13 04:00:20 EST
This bug has been copied from bug #1296694 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 6 errata-xmlrpc 2016-03-22 10:47:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0468.html
Comment 7 German Parente 2016-08-04 12:33:23 EDT
*** Bug 1363883 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.