Bug 1298106 - preserve sparseness for drive mirror operations over distributed storage
preserve sparseness for drive mirror operations over distributed storage
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.1
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Fam Zheng
Virtualization Bugs
: ZStream
Depends On: 1232914
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 04:06 EST by Jan Kurik
Modified: 2016-02-26 11:54 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1232914
Environment:
Last Closed: 2016-02-26 11:54:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-01-13 04:06:02 EST
This bug has been copied from bug #1232914 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Fam Zheng 2016-01-19 04:12:48 EST
To verify the bug, QE should test the blockdev-mirror command, which is introduced as a fix to this bug.

The command is going to be used in conjunction with blockdev-add.

Generally, all the existing drive-mirror cases apply to blockdev-mirror. In particular, what is wanted in this BZ is enabling zero detection feature by specifying "detect-zeroes=unmap" to the target image. The QMP pseudo command lines are:

    # blockdev-add {'options': {'node-name': 'target0', 'driver': 'raw',
    'detect-zeroes': 'unmap', 'file': {'driver': 'file', 'filename':
    '/var/tmp/dest'}}}

    blockdev-mirror {'device': 'd0', 'target': 'target0', 'sync': 'full'}
Comment 5 Peter Krempa 2016-02-04 11:48:13 EST
blockdev-add can't be used by libvirt upstream at this point. I've noted this in the parent BZ. Moving back to ASSIGNED to track backport of the new required patches.
Comment 6 Ademar Reis 2016-02-26 11:54:36 EST
We're withdrawing this from the z-stream because the fix is more complex than we anticipated. It'll be fixed in 7.3, but not in the z-stream (see bug #1232914).

Note You need to log in before you can comment on or make changes to this bug.