Bug 1298109 - tmpfs is unexpectedly mounted on /tmp in rhel-7
tmpfs is unexpectedly mounted on /tmp in rhel-7
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: systemd-maint
Branislav Blaškovič
: ZStream
Depends On:
Blocks: 1339488 1298209
  Show dependency treegraph
 
Reported: 2016-01-13 04:21 EST by Mohit Agrawal
Modified: 2017-01-09 00:50 EST (History)
8 users (show)

See Also:
Fixed In Version: systemd-219-20.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298209 (view as bug list)
Environment:
Last Closed: 2016-11-03 20:50:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2121951 None None None 2017-01-08 23:15 EST

  None (edit)
Description Mohit Agrawal 2016-01-13 04:21:22 EST
Description of problem:
tmpfs is unexpectedly mounted on /tmp when user start any unit file that configured PrivateTmp=true


Version-Release number of selected component (if applicable):
systemd-219-19.el7.x86_64

How reproducible:
Always
Steps to Reproduce:
1) df /tmp
 df /tmp
Filesystem                            1K-blocks     Used Available Use% Mounted on
/dev/mapper/rhel_dell--per630--2-root  52403200 19977388  32425812  39% /

2 ) systemctl status tmp.mount; 

But after start systemd-timedated it is start automatically and created mount-point.
3 ) systemctl start systemd-timedated; 
4) df /tmp
Filesystem     1K-blocks  Used Available Use% Mounted on
tmpfs            8010868     0   8010868   0% /tmp



Actual results:
/tmp is created new mount point on tmpfs

Expected results:
mount point should not create automatically.

Additional info:
Comment 3 Lukáš Nykrýn 2016-01-13 04:49:41 EST
Just a small note, workaround for this issue is to mask the tmp.mount by calling:

systemctl mask tmp.mount
Comment 13 errata-xmlrpc 2016-11-03 20:50:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2216.html

Note You need to log in before you can comment on or make changes to this bug.